Survey123 Connect Error 403 prevents login

352
5
Jump to solution
05-15-2020 02:00 PM
JayPuckett
New Contributor

When I try to open the sign in dialogue in Survey123 Connect 3.9.120, I get redirected to Error: 403 This request needs to be made over https.  This error persists when I change the login portal to my organizational login page (using https) or simply to https://arcgis.com.  I cannot get past the error to attempt to log in. I am able to log in without any issues in Survey123 Classic.  No one else at my organization is having this problem although they are all on previous versions. Any thoughts on how to get around this would be greatly appreciated.

0 Kudos
1 Solution

Accepted Solutions
Shwu-jingJeng
Esri Regular Contributor

Hi Jay,

Sorry for the late reply. The 403 error you received might relate to the network security issue. We had redesigned the login dialog page to enhance the log in experience in 3.10. We will release 3.10 soon and the RC build is available on our EAC site that you can download and use it now.

Please try the 3.10 RC instead.

View solution in original post

0 Kudos
5 Replies
JayPuckett
New Contributor

Update: I have tried uninstall/reinstall of Survey123 Connect and no success.  I still cannot get the login screen to load at all.  Everything is working normally in Survey123 Connect Classic (2.9.3) and in Beta (3.10.188).  

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Jay,

Are you able to choose "ArcGIS Online" option and proceed with your log in in 3.9 Connect?

0 Kudos
JayPuckett
New Contributor

I can choose ArcGIS Online but I get the same result as if I try to log into my organization's AGOL site.  

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Jay,

Sorry for the late reply. The 403 error you received might relate to the network security issue. We had redesigned the login dialog page to enhance the log in experience in 3.10. We will release 3.10 soon and the RC build is available on our EAC site that you can download and use it now.

Please try the 3.10 RC instead.

0 Kudos
JayPuckett
New Contributor

I installed 3.10.239 and the issue has been resolved.

0 Kudos