Survey123 - bugs in Annotate/draw tool?

648
7
07-09-2018 06:35 AM
New Contributor

The annotate/draw option in survey123 is a really useful tool that I am currently using in a survey set up for contractors to communicate project progress on a pre-drawn grid.  However, the tool can be frustrating to use if you need to make more than a couple of annotations.  For example, drawing on the grid often causes previously created notes/lines to completely disappear or change colors randomly.  The undo button will sometimes correct this behavior, but often it is necessary to erase the annotations completely and start over.

Is this a known issue and/or does anyone have any suggestions for working with annotations more efficiently?

Thanks!
Joy

Note: could this be an iOS problem?  We have tested on multiple devices, but they are all iOS.

Tags (3)
Reply
0 Kudos
7 Replies
Esri Frequent Contributor

Hi Joy,

Can you please confirm what version of the app you are using, and what iOS version you have installed? Note that we just released version 3.0 last week, can you confirm if you still experience the same issues with latest version?

Phil.

Reply
0 Kudos
New Contributor

Hi Phil,

Thanks for the response.  I just did the update and now the option to annotate is gone!  I republished the survey and redownloaded to my ipad, but still the same.  Also tried to change from annotate to draw - same results.  The old version is still working on my iphone.  Any suggestions?

Thanks,

Joy

Reply
0 Kudos
Esri Frequent Contributor

Hi Joy,

We have identified this issue with default image values on an annotate question are not loading correctly in the form and require deleting the first displayed entry, then opening the annotate button. We hare aiming to fix this in a future release and update of the 3.0 app.

Phil.

Reply
0 Kudos
New Contributor

Hi Phil,

Please disregard my previous response - for some reason the png was pre-loaded and as such as uneditable.  Deleting the pre-loaded image brought back the option to annotate.

I updated the app and the new functions are visible (annotate map, etc.), however the same bugs remain

Reply
0 Kudos
Esri Frequent Contributor

Is the problem when you are trying to edit previous saved drafts or sent surveys and edit the annotation? Or is it happening every time you try to create a new annotate?

Are you able to share your survey and media folder (zip up the entire survey folder) from Designs, so that we can take a further look and try to replicate.

Phil.

Reply
0 Kudos
New Contributor

Hi Phil,

The bugs happen in fresh surveys; I don't usually work with drafts or previously sent surveys.  A link to the zipped file is below.  This is an awesome feature and we're working around the bugs for now.  Thanks for looking into this!

I still haven't been able to nail down exact functions that cause the lines to disappear - it seems to be random.  Here's an example: The annotation in black in the image on the left was created perfectly, then I added the blue line and the entire black sketch turned blue.  Other times the entire black line would disappear.  This happens regardless of the color, line size/length, shape, location on the grid, etc. 

I have a new survey user using a samsung phone - I'll find out over the weekend if he is having the same issues.

Link to zipped survey: Dropbox - Stillwater Basin DASH.zip 

Thanks again!

Joy

Reply
0 Kudos
Esri Frequent Contributor

Hi Joy,

Using your survey I was unable to replicate the issues you have with annotate and draw feature. The colours used and different features of the drawing tool are working as expected. I could not get colours to change, or drawing to become cleared or removed when adding new lines/text to the same image.

Phil.

Reply
0 Kudos