survey123.arcgis.com data viewer not loading and crashes when clicking on individual entries

651
6
Jump to solution
04-14-2023 09:14 AM
BrianTruong
New Contributor II

Hello All, 

Got an error that recently started happening when I access the data tab of a survey on survey123.arcgis.com. I'm able to view the data, however when I click on an individual entry the side bar would pop up and load for a bit and then stop and crash the page. Typically I'd be accessing individual entries to edit or delete them as needed. 

 

I've attached two photos to this, showing the data tab before clicking on an entry and after an entry. I've tried clearing my cache as well as doing this on incognito mode. I'm using Chome. 

 

Thanks for any help! 

 

Brian

0 Kudos
1 Solution

Accepted Solutions
Richard_Purkis
Esri Contributor

Hi @BrianTruong 

Thanks for getting in raising this with us.

I was recently working with a customer and we came across the following defect:

  • BUG-000157076: Performance issue on the ArcGIS Survey123 website, on the Data tab and 'Form view' enabled, for a survey that includes an image question and an external choice list.

Does this defect description match the issue you are facing?

Thanks

View solution in original post

6 Replies
DougBrowning
MVP Esteemed Contributor

My guess would be some kind of special char or field name with an issue.  Look for anything funky.

You can also use a webmap to review and delete to get around this.

0 Kudos
BrianTruong
New Contributor II

Hey Doug,

Do you know what kind of special chars I should be on the lookout for? I'm combing through around 180 entries to sort through. 

Any clues would help! 

 

Thanks Doug!

0 Kudos
ChristopherCounsell
MVP Regular Contributor

The data appears to load ok, you can see it in the table.

This viewer attempts to show the data with the Survey123 web form. If you've built the survey with Survey123 Connect and use functionality that isn't supported in the web form, sometimes you'll have issues viewing submitted surveys from the survey123 website.

Does this sound possible? Can you share the XLSForm? Do you have issues accessing and editing the data via the field app inbox, or via a wep map viewer?

0 Kudos
Richard_Purkis
Esri Contributor

Hi @BrianTruong 

Thanks for getting in raising this with us.

I was recently working with a customer and we came across the following defect:

  • BUG-000157076: Performance issue on the ArcGIS Survey123 website, on the Data tab and 'Form view' enabled, for a survey that includes an image question and an external choice list.

Does this defect description match the issue you are facing?

Thanks

BrianTruong
New Contributor II

Hi @Richard_Purkis

Yeah that matches the issues I'm currently facing. Are there any plans on having the bug fix in place soon?

Thanks!

0 Kudos
Richard_Purkis
Esri Contributor

Hi @BrianTruong 

I'm glad I could help. The defect is still in review. I recommend you raise it with your Tech Support team that you are facing this issue. Having more accounts attached to the defect indicates to the development team that other customer's are facing the isuse.

Once attached to the case, you will also have the option to attach an escalation defect in MyEsri if this is a major blocker for you.

Hope this helps 

0 Kudos