Survey123 App - Survey description not appear

1282
13
05-18-2023 10:28 AM
YHH
by
New Contributor II

Hello all,

I have been creating my survey using Survey123 version 3.17. I am still in the process of designing the survey. When I click "Preview", I can see my survey description, but the description doesn't appar when I see my survey in the ArcGIS Survey123 App. I have tried the iPhone and Microsoft desktop versions. The Survey elements (survey header, description, footer) are on. I re-downloaded the app, but it still have the same issue.

I believe I could see the survey description last year. Is it an error?

Please advise.

0 Kudos
13 Replies
ChristopherCounsell
MVP Regular Contributor

There are three parts to Survey123. Desktop (Connect), website (ArcGIS Online) and field app (survey123  mobile app).

If you make an update in connect, it goes to the website. The field app will only get it if you download the updated form.

Can you please ensure you have a) published the survey form and b) downloaded it to the field app.

If not successful, can you please elaborate on where the survey description is? in the survey questionnaire? item details?

0 Kudos
YHH
by
New Contributor II

Thank you for your reply!

I use the Survey123 on ArcGIS Online to create my survey and the Survey123 Mobile App to display the survey (I already downloaded the app). 

The survey description is on the Survey123 on ArcGIS Online. I can see the survey description when I click "Preview", but I can not see the description on the Survey123 Mobile App. It starts showing from the questionnaire I created.

ChristopherCounsell
MVP Regular Contributor

The 'survey description' section of the web designer is a 'note' question that allows you to add text to your survey. It should be supported in the field app.

I think the issue is that you have made changes to your survey, but you have not published them. They will appear in the 'preview' but won't appear in the form in either the web browser or field app, as the changes have not been committed to the actual, published survey.

If you want your changes to the survey to appear, publish them.

https://doc.arcgis.com/en/survey123/browser/create-surveys/previewyourform.htm

https://doc.arcgis.com/en/survey123/browser/create-surveys/publishsurvey.htm

 

0 Kudos
YHH
by
New Contributor II

Thank you for your reply again magisian. I did 'published' my survey (I tried many many times like, save published save published), but the issue is still persist. So, I used a 'Note' question and used like a survey description section. Then, I turned off Survey description button from the Survey elements. Now I can see my survey description in the field app. 

0 Kudos
GeospatialClarity
New Contributor

I am seeing the same thing, a missing survey description. The survey, created in AGOL, is published and the preview shows it, but not the desktop app nor the android app. 

0 Kudos
ChristopherCounsell
MVP Regular Contributor

Preview = preview unpublished changes. It's not a good reference point to discuss against. I'm not sure if either of you have a legitimate issue where the description isn't appearing in the field app, or if you have not published the changes and then downloaded the form.

  1. Publish the survey. Don't preview it. If you want to see it as it is currently live in the WEB FORM, launch the survey in a browser i.e. follow the steps below to launch the survey in the browser:
    https://doc.arcgis.com/en/survey123/browser/create-surveys/sharesurvey.htm#GUID-D7BD77AF-C8BE-4F56-9...
  2. Confirm that it's working as expected in the web browser as above. This is your published survey and reference point for what is working in the browser vs the field software.
  3. Download the survey to the Survey123 field app software. You will need to download the updated form, if you have made updates to the survey (i.e. adding a description and publishing the update).
  4. Confirm you are on the latest version of the Survey123 field app.

If the issue persists with the above steps followed and your are on the latest version, then it suggests that the behavior is not working as expected.

0 Kudos
melj
by
New Contributor

I'm having the same issue. where the published survey (created on web) that is opened in the field app just shows a blank of the description (in my case the first page is description, questions start on the next one). But when I open my published survey via web, the description is correctly displayed. 

James_Whitacre_PGC
New Contributor III

I am also experiencing this behavior. I updated the text and background colors and that didn't fix anything. It looks fine in the mobile app. Is this a bug?

@Ruth_JiatengXu you seem active on other issue similar to this one...any help you can provide?

0 Kudos
Ruth_JiatengXu
Esri Contributor

Hi @James_Whitacre_PGC @melj @YHH @ChristopherCounsell @GeospatialClarity 

Thanks for sharing here! The survey description is currently only supported in the web app. The survey description published in the web designer will become the hint of the note question called generated_note_form_title. This generated_note question is hidden by default in the Connect and Field App.

If you want to see the survey description in the Connect and Field App, please copy the hint to a note question.

Doc reference: https://doc.arcgis.com/en/survey123/desktop/create-surveys/xlsformnotes.htm#ESRI_SECTION1_31E80EF0A3...

Thanks,

Ruth