Survey 123 - exporting data not responding

273
7
02-09-2021 08:42 AM
ChipBrown1
New Contributor III

We have created and been using successfully a survey published through Survey 123 on the web.  Every day, we need to download the survey results as an Excel file.  Most days this works, but some days the export does not function: no file is exported and the download indicator arrows next to the "exporting" button just spin.

A file is created in ArcGIS Online, but when I download it and try to open it, I get the message "Excel cannot open the file '[filename].xlsx' because the file format or file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file."

 

Tags (2)
0 Kudos
7 Replies
DougBrowning
MVP Frequent Contributor

This happens to be Exporting as a GDB also on the regular.  Esp if the file is larger like 10 GB.  Also sometimes I get a file but it is corrupt.  We have some that will be 40 GB next year so I get worried.

This is prob a AGOL issue though not a 123 issue.

0 Kudos
MelissaMiracle1
New Contributor

I am having the same issue downloading the data as an Excel file in Enterprise Portal.  

0 Kudos
ChipBrown1
New Contributor III

Melissa:

I never really had a definitive answer to this, but it did resolve itself I think. Not much of an answer, but I wanted to respond so you were not left hanging.

Chip

BrianShepard
Occasional Contributor

@ChipBrown1 Is this still working for you, and has it been working consistently?  We published a survey recently with very few data records and I'm having the same issue (exporting icon just keeps spinning and the .xlsx and .zip (.csv) exports that appear in my AGOL content are invalid). I can't imagine my issue is related to file size with just 7 records of text/numeric data.

0 Kudos
BrianShepard
Occasional Contributor

I may have answered my own question to some degree. I finally just let the export run and it completed after 15-20 minutes. Another user noted the same thing. After that first successful Excel export, subsequent exports only take a few seconds for both of us. Any ideas why the time to export varies so dramatically (i.e., 20 minutes or 5 seconds)? Is it at all related to the first export for each user?

0 Kudos
ChipBrown1
New Contributor III

Sorry for delay, Brian. The information you provide is helpful.  I have not heard of this issue cropping up for our folks since it resolved itself. Someone else will need to chime in regarding the variability in time for processing.

0 Kudos
BrianShepard
Occasional Contributor

No worries. Wonder if we had a similar experience and after waiting for it to complete once, it just magically seems to work now. I'll keep an eye out as we deploy additional surveys and export data.

0 Kudos