Submission url Issue

503
2
01-04-2019 01:25 PM
TylerShelton1
New Contributor II

I'm running into an issue when attempting to publish a survey to an existing hosted feature service with two related layers.When i go to publish the service i am getting the error.

" The custom feature service submission url is not compatible with this survey (undefined is a undefined , a feature is required for esriGeometryPoint."

Any help appreciated!

0 Kudos
2 Replies
by Anonymous User
Not applicable

Hi Tyler,

Are you using AGO or Portal, if so what version? And what version of Connect are you using?

How was your existing hosted feature service created? What type of relationships and how are the created, and are the related tables only tables (without geometry) or layers (with geometry)?

Can you provide a copy of your xlsx form?

Regards,

Phil.

0 Kudos
janderson_ksninc
Occasional Contributor

I'm having a similar issue. I created a hosted feature layer with a related table. The feature layer consists of a polyline shapefile and a related table. When I change the question type from text to geopoint, I get the following error:

"Upper_Mormon_Slough_Survey_Results is a Table, a feature layer is required for esriGeometryPoint"

Is is possible that I need to put the whole survey into a repeat so that the survey will related to the table? If so, is there a way around this? I'm trying not to confuse the people who will use this as they will likely see the repeat buttons at the bottom of the survey.