Strange Error Message

449
3
04-25-2022 11:49 AM
LydiaWerner_MAC
New Contributor III

Phoning a friend for a very strange error message I am getting on a survey I created. I have a Creator level license. Hoping the brain trust has some ideas!

 

Survey123Error_online.png

 

0 Kudos
3 Replies
Katie_Clark
MVP Regular Contributor

So, uhhh....I've never had an error quite like that before but I'll try to help (unless someone else more knowledgeable jumps in!)

So, looks like you're creating this survey in the web version rather than Connect, correct? 

This is just a wild guess, but I wonder if that apostrophe in Allen's Hummingbird is causing an issue? That's an option from a select_one or select_multiple question, correct? 

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
0 Kudos
Katie_Clark
MVP Regular Contributor

I also found these articles that reference the same "FormLogicError" message....perhaps there's something in them that could help?

https://community.esri.com/t5/arcgis-survey123-questions/formlogicerror-could-not-evaluate-model-ins...

https://community.esri.com/t5/arcgis-survey123-questions/formlogicerror-in-survey123-webapp-with-rel... 

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
0 Kudos
LydiaWerner_MAC
New Contributor III

@Katie_Clark I have gotten this message intermittently between late last week and today. I created the survey in Connect, but was testing it out in a web browser. This is a select_one question as well. I have a separate CSV for this specific question (and another as well). I've attached my survey form and choices list.

0 Kudos