select_one results do not show up in Inbox

172
6
a month ago
JoseVidal
New Contributor III

I setup 2 simple surveys both using the same "service" (that is, the second one uses the first one as a feature service. The second one has the Inbox activated so it can see the submissions sent from the first.

This works, the second survey gets results in the Inbox and can view and edit them. However, the select_one question always appears blank in the second one, even thought it was filled in the first one.

 

This looks like a bug in survey123. Is it?

First survey:

 

JoseVidal_0-1618522051168.png

 

second survey:

 

JoseVidal_1-1618522097100.png

 

In the Demo I first fill out the survey and submit it. Then I go to the second survey, to the Inbox, refresh where I see the survey I just submitted, then Edit. I can see the value I entered for the number, but the select_one question is blank.

0 Kudos
6 Replies
Philip-Wilson
Esri Frequent Contributor

Hi @JoseVidal,

What version of Survey123 Connect and field app are you using?

What are the value types of the rating question in th choice list, strings or numbers?

Are you able to share your xlsxform file (xlsx file from survey folder) so we can take a closer look?

Regards,

Phil.

0 Kudos
JoseVidal
New Contributor III

Here are the versions:

JoseVidal_0-1618828171662.png

 

JoseVidal_1-1618828201186.png

The rating question has name set to 1,2,3,4,5 and label to 1 star, 2 stars... It is the default question

I am attaching the two spreadsheets below.  Thanks!

0 Kudos
ZacharySutherby
Esri Contributor

Hello @JoseVidal

Thank you for passing along the XLSForms! I've tested on my end and I am not able to reproduce the same behavior: 

ZacharySutherby_0-1619129198088.png

 

The first thing that comes to mind is maybe when the original TestCalculation survey was published the option to Create coded value domains from choices may not have been selected. 

In ArcGIS Online if you navigate to the Item Details page for the hosted feature service your surveys are pointing to > select the Data tab > Fields > select the Rating field > Does that field have a list of domain values? 

ZacharySutherby_1-1619129389091.png

 

Thank you, 

Zach

0 Kudos
JoseVidal
New Contributor III

Thanks, but, I am new to arcgis. I managed to find the "hosted feature" that corresponds to the TestCalculation survey in arcgis, but, I can't find the page you show above. I don't know where to click to get to the "Item Details page". This is as far as I got:

 

JoseVidal_0-1619136329297.png

 

0 Kudos
JoseVidal
New Contributor III

Ok, I found it. It does have a list of values:

 

JoseVidal_0-1619137080318.png

 

0 Kudos
JoseVidal
New Contributor III

Well, I tried it all again and now it works.

I did not change anything so, don't know what was the problem.

0 Kudos