Reporting Failed to print Map and Failed to load web map

478
3
01-25-2023 08:57 AM
KarliJaeger
New Contributor

Hello, I am trying to make a report from Survey123. I am trying to add map image to my report but I keep getting the same error. I have tried my different options from different post here. 

"An error occurred when rendering by the report engine. Failed to print map for ${SanitaryBackup_point}. Failed to load web map": 5d430cb.....9ad4b. Timeout exceeded."

I have tried most of the examples in the Report templates page. No matter what I change or add, it still gives me the same error. Enabled Sync is unchecked and Allow others to export to different formats is checked.

Any help suggestions or help. Thanks

0 Kudos
3 Replies
Richard_Purkis
Esri Contributor

Hi @KarliJaeger 

The source of the issue is not likely to be the report type but the map in this case. To prove this make a test survey with a geopoint question and then generate a report for that survey. Does this work?

If so, what data is in the map that is failing? Where is it coming from?

Hope this helps

0 Kudos
KarliJaeger
New Contributor

@Richard_Purkis  Thanks for your help! Made a test survey with just geopoint and did not change any of the basemaps, and it worked just fine. But when I change the basemap to one of our basemaps with our layers from portal, the error came back. So our problem is now why it does not like our basemaps? Would you have any idea where to start looking into this?

0 Kudos
BlairMcclenathan
New Contributor III

I had this same issue when publishing with Surve123 Connect. I recreated the form in the online editor and published it with our org basemap and have had no issues. Not sure why there is an issue, but at the very least there seems to be a workaround.

0 Kudos