pulldata does not return values if lookup is a 0?

704
2
Jump to solution
01-27-2021 11:34 AM
DougBrowning
MVP Notable Contributor

I have a pulldata that does a lookup for values 0-4.  1-4 all work fine but 0 does not ever work.

Attached is a simple form that shows this.  This used to work I think.

 

Also as a side note I can no longer find the 123 formulas page or other help.  Not coming up on google like it used to.

thanks

0 Kudos
1 Solution

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello @DougBrowning

I have gone ahead and logged an internal issue for 0 not being returned by the pulldata() function. This does work in 3.11 and the Webform. Unfortunately it seems to be a regression with the current 3.12 beta build. 

As for the Survey123 formulas page not showing on Google, I've noticed the same thing unfortunately that's up to Googles search algorithm we don't have much control over it. I had tested with Bing and DuckDuckGo and they both work like Google used to. What I've been doing lately is selecting the first doc.arcgis.com link that pops up and then searching for it directly within the Survey123 documentation site. Bookmarking the page may also ease finding the doc page.

Thank you, 

Zach

Thank you,
Zach

View solution in original post

2 Replies
ZacharySutherby
Esri Regular Contributor

Hello @DougBrowning

I have gone ahead and logged an internal issue for 0 not being returned by the pulldata() function. This does work in 3.11 and the Webform. Unfortunately it seems to be a regression with the current 3.12 beta build. 

As for the Survey123 formulas page not showing on Google, I've noticed the same thing unfortunately that's up to Googles search algorithm we don't have much control over it. I had tested with Bing and DuckDuckGo and they both work like Google used to. What I've been doing lately is selecting the first doc.arcgis.com link that pops up and then searching for it directly within the Survey123 documentation site. Bookmarking the page may also ease finding the doc page.

Thank you, 

Zach

Thank you,
Zach
DougBrowning
MVP Notable Contributor

Thanks Zach.  I was using 3.12 when i wrote this but our 3.11 apps are also seeing it on exisiting forms so was not sure.

thanks for logging.  I put a coalesce around it since the only return of blank is 0 so I can fake it for now.

0 Kudos