Problems accessing attachments from Survey123

536
1
09-18-2020 01:41 PM
LisaDygert
Occasional Contributor

Hello,

I have created a Survey123 app that is working well.  It does not contain spatial data as I don't need it to initially.  (The users aren't GIS savvy and it would take them far longer to have to search for a point than to just enter in the known ID value for it).  

Basically, we get pdf files with information we need to enter into a database.  So, the Survey123 app allows the user to enter in the needed information and then also attach the pdf file as part of the survey.  

I am now trying to relate the output of the Survey with existing spatial data (points) and create a web mapping application that will allow staff to view the pdf file attachment and I cannot figure out how to get that to work.

The survey123 data is stored in our SDE and I have created a relationship class between a point feature class, the survey data SDE table, and the attachment data SDE table and then publish that to AGOL.  I relationship works between the points and the survey responses, but I cannot get the attachment to open.  It gives me the name of the attachment, but I am not sure if it is actually there.

I have also tried creating a spatial view so that I can only show the points that have had the survey data completed for them and then relate that to the attachment SDE table and publish that to AGOL, but I have the same problem with the pdf file not opening.

I am using Survey123 3.10, and I have both ArcGIS Online 10.7.1 as well as ArcGIS Pro 2.4, and I use AGOL.

Any ideas of how I can make this work?  I won't attach any files because I am not sure how much that would help.

The survey123 table has a field for a WSSN number, which can be related to points with WSSN numbers across the state (there are thousands of them).  The relationship class seems to work just fine, but I cannot get the pdf file to open.

I have created similar Survey123 apps, but with spatial data (points) and I have no problem accessing the attachments from that.  Is the difference in whether or not there is spatial data in the survey123 output dataset, whether the data lives in SDE versus AGOL cloud, both, or is there some other reason?

I would really appreciate any ideas of how I can get this work.  

Thanks in advance,

Lisa

0 Kudos
1 Reply
JamesTedrick
Esri Esteemed Contributor

Hi Lisa,

Apologies for the delay in response.  Normally you do not need to bring the attachment table directly into a relationship; those tables are managed by the geodatabase and shouldn't be accessed on their own in normal use by clients like ArcGIS Pro.  

It would probably take a bit more of a discussion to work out the best solution for how your data is structured, but one of the quickest would be reverse the relate - update the Survey123 information with the locations from the existing dataset, add other fields from the existing dataset as necessary, and use the Survey123 data as the layer you are viewing in a web application.

0 Kudos