Problem with public survey

2172
27
04-05-2018 05:49 PM
Occasional Contributor

Hi, I’m new to Survey123 and trying to set up a survey with five requirements:

  • It must be public, no AGOL credentials required
  • It must be able to collect data in the app while disconnected, submitting it later
  • Users should not be able to see other users’ submissions
  • It must contain a photo
  • It must contain location

I haven’t had any luck with the public aspect.  Despite reading this blog post and other doc, changing feature layer settings, trying steps in different orders, whenever I attempt to submit data the app asks for AGOL credentials.  Perhaps what I’m trying isn’t possible but I think it’s much more likely that I’m just overlooking something.

 

After authoring and publishing the survey, I go to the main feature layer’s settings and set them accordingly:

  • Editing: “Enable editing.” Is turned on, the other three settings are turned off.
  • What kind of editing is allowed?:  Add features
  • What features can editors see?:  Editors can’t see any features
  • What features can editors edit?:  Disabled
  • What access do anonymous editors have? The same as signed in editors
  • Export Data: False

I then went to the field worker service and where applicable made those settings match, then from the Collaborate tab in Survey123 made the survey available to Everyone (Public).  When I attempt to submit a survey from the app, it still asks me for AGOL credentials.  (I also tried making the survey public first, then changing feature layer settings.)

 

If anyone has any ideas about what I’m overlooking I’d definitely appreciate it.

Reply
0 Kudos
27 Replies
New Contributor II

Have you shared it in AGOL yet?

Reply
0 Kudos
Occasional Contributor

Yup, unauthenticated users can open the link and download the survey without issue, just can't post.  The survey is public, the field worker view is public, and the core feature layer is private.

Reply
0 Kudos
New Contributor II

Did you create the survey in Connect or using the Survey for ArcGIS  Website.

Reply
0 Kudos
Occasional Contributor

I used the website.

Reply
0 Kudos
New Contributor II

As a test try making the core feature layer public as well.

Reply
0 Kudos
Occasional Contributor

Still no luck with everything public, and I've tested adding a point through the REST API (just through a browser) and it worked without credentials.

Reply
0 Kudos
Occasional Contributor

Also, anonymous submission worked via the web link, seems to be an app-specific issue.

Reply
0 Kudos
Regular Contributor

Hello James

Here are some notes I made for myself on how to share a survey123 with the public but keep the responses hidden.

After making the survey I had to open my AGOO and find the folder that was automatically created. It contained the three files shown in image 2.

To make a public survey123 where data not visible to the public:

  1. Go to your AGOO my content and find the folder with your survey. In the example below the folder is called Survey-RUSD
  2. You need to change two checkboxes to change in the Feature Layer (hosted, view). This layer has the word fieldworker at the end of the  layer name. Open the item details (click on ellipsis …) and open the settings tab. See the example below in image 1.
  3. the Feature Layer (hosted, view) and Form are shared with the public (globe icon).  See the example below in in image 2
  4. the Feature Layer (hosted) is not shared with the public (padlock icon). See the example below in image 2

      Image 1 What you will see when you open the settings tab in item details of the Feature Layer (hosted, view).

      Image 2  The field worker layer item details (ellipses) is where to change the default settings. Two items are shared       with the public and one is not.

Allison

Occasional Contributor

Thanks for the help Allison, but I'm still seeing the same issue.

What makes it especially strange is that anonymous submission works via the web form but the app still asks for credentials.  Like I said I'm new to Survey123 but something seems very odd about that...  It's not isolated to one device either, tested on three different devices now with the same results.

Reply
0 Kudos