Old forms not working when the form name contains apostrophe

266
2
05-12-2021 10:13 AM
JamieKelly1
Occasional Contributor

I am updating an older form and found that my pulldata from csv function was no longer working.  I could not figure out why (coincidentally it was this data that I was updating).  After taking the problematic questions aside into a new survey, they worked fine.  Then I decided to create another new form this time giving the form a name that contained an apostrophe, which survey123 displays the apostrophe as 'X'.  Next I again copied in the problematic questions, and then the pulldata no longer worked.

Is there an easy way to update the form's name?  Or is this a known issue with a workaround?  I do not want to republish a new survey, only update the old one since I want to keep all the survey data together, and I also have automated process built around downloading the survey data locally.  Those automated process would then also have to be updated for the new service url and it would not contain the historic data.

Also, I haven't republished any changes yet that I am making to my form, but am noticing the original form is still working even though the name contains an apostrophe.  Is it only a glitch in survey123 connect?

Any help appreciated.

Cheers,

0 Kudos
2 Replies
Philip-Wilson
Esri Notable Contributor

Hi @JamieKelly1,

Can you confirm if you are using web designer or Connect to create/publish the survey with an apostrophe and where you saw the 'X'? Can you take a screenshot? Also what version of Connect?

Apostrophe's are supported in the form name if created from web designer or Connect, I just tested and both worked fine, and the form item and feature layer I see in AGO contain the apostrophe. 

Are you wanting to update the survey name (form/title name) or the actual form item and feature service item name?

Regards,

Phil.

0 Kudos
JamieKelly1
Occasional Contributor

Hi,

Just running into this issue again with a different survey.  The survey's name contains an apostrophe and the pulldata function will not return any values from the csv within survey123 connect (v. 3.14.281 - windows x64).

0 Kudos