Map scale issue in custom Feature Report template for Survey 123

617
2
06-23-2020 10:38 AM
by Anonymous User
Not applicable

Creating a feature report in Survey 123 and I created a custom feature report template. Any adjustment I make to the scale for the map in the template based on the location field is not reflected in the Sample Report generated, is there any other syntax I can try?

So far I have attempted:

${Location|mapSettings:””:100000|size:319:239}

${Location|mapSettings:”8bf7167d20924cbf8e25e7b11c7c502c”:100000|size:319:239}

${$shape|mapSettings:”8bf7167d20924cbf8e25e7b11c7c502c”:100000|size:319:239}

I have tried various scale values but the feature report always exports the same scale that only shows the full extent of the feature, not at the scale I'm defining in the feature report syntax.

Please let me know if I can provide any other information on this and thank you for any guidance and troubleshooting offered.

0 Kudos
2 Replies
Jim-Moore
Esri Regular Contributor

Hi Amanda TerBeek

Appreciate this post is going back a while - were you able to sort out the map scale in your feature reports?

The syntax in your template works as expected for me and is consistent with the documented syntax. I tried using your template for one of my own surveys; when changing the scale value the map scale in the output report changed accordingly, e.g. for a geopoint question named "location":

${location|mapSettings:"":50000}

Best,

Jim

0 Kudos
DWRTylerArnold
New Contributor

Is there a way to remove the map in general? When I populate a report I have the ${SampleLocation}, but I would just like the GPS points to show up and not the map image? thank you for the help. 

0 Kudos