Map (Geoshape) missing in report

02-22-2022 12:48 PM
New Contributor III


I have a report template that loads perfectly well as a template in Survey123, but where I have a statement to display my geoshape on a map, in the report which is produced, I simply see the word 'true', no map, no geoshape. I have tried with and without setting a custom basemap, along with other parameters, but get the same result.

I have tried:-

${polyarea | size:300:400}


${polyarea|mapSettings: “4b3e8c05f2d842e094f3d1d4b18b306c”| size:840:1190}



I have also noticed that the map/geoshape does not appear in the data panel in Survey123 website, although it does appear on the map.



Having run numerous tests, I feel it must be to do with a setting in the survey itself, because the map appears  if I create a new survey from my xls and use the same report template. 

Any ideas anybody?

Thanks for any help.



0 Kudos
1 Reply
Occasional Contributor

I'm not sure if this will help at all but for my geopoint section of my form, this is what I have.  I'm pretty new to creating custom forms but my coworker was able to help me figure this out and it seems to work nicely in the form.

${$shape | mapSettings: “c4341c8319b54aedb764ed9d614320fd”: 1500 | drawingInfo: “currentLayer” | size:250:0}

0 Kudos