Select to view content in your preferred language

map for geopoint question, iOS vs web?

402
2
10-12-2023 01:51 PM
ChuckS
by
New Contributor III

I have a geopoint question in my survey. Most of my users use the iOS field app and the geopoint question displays a map for the user to center on the correct location.

When I run the survey in a web browser, the geopoint question displays a map that displays all of the previously submitted points. This was unexpected and is distracting for the user. There are so many points, in some cases, it's difficult to see the map. Does anyone know how I can avoid having the points from previously submitted surveys showing up on the map when using the survey in a web browser? This behavior doesn't happen on the iOS field app.

Thanks, Chuck

0 Kudos
2 Replies
ZacharySutherby
Esri Regular Contributor

Hello @ChuckS

If you published the survey from Connect there is an option to create a web map that is enabled by default. What's likely happening is you are seeing the linked web map in the web app. If you don't want the web map you can delete it from your content, or if you would like to keep the web map but have it not display in the form under Linked Content in Connect you can unlink the map. 

Thank you,
Zach
0 Kudos
ChuckS
by
New Contributor III

Hello Zach,

Thanks for the suggestion. I definitely need the map to analyze data after surveys have been submitted. Each time a survey is submitted, I need the geopoint answer (a lat/lon point) to be added to the map. For this reason, I think that I cannot unlink the map from the survey. Is that correct?

As an experiment, I took your suggestion and unlinked the map in  Connect. After re-publishing the survey and viewing it in a web browser, the previously submitted points are not visible (makes sense) but, now the map shows satellite imagery. I believe that I must have a map linked to the survey.

I'd like to have the same behavior as the iOS field app, to not show previously submitted points, but it appears that's not possible when using the survey in a web browser. I don't want my users seeing all the previously submitting points. I guess the solution is to say that my survey cannot be used in a web browser.

Update: I re-linked the same map under Linked Content in Connect then published the survey. Now, when I view the survey in a web browser, the geopoint question no longer displays the previously submitted points. I'm not sure what happened.

Thanks, Chuck

 

0 Kudos