Maintain attachment environment setting not working

124
5
10-29-2018 05:23 PM
Highlighted
New Contributor III

I have two point fcs that I exported from arcGIS online. Each fc has a two one to many table relates and two relationship classes that were derived from two repeats within a survey in survey123. One table relate is a table of photos for each point and the other is a table of rows with data for measurements for each pipe at the site (each point in the fc is a site).  I had to change my survey so now I have two separate fcs one from the first survey and one from the second after I changed it slightly. I am trying to append one to the other, so that I have one fc with two table relates (all the points with all pipes and all photos). To do this I used the append tool while checking the maintain attachment environment setting box, but the output continues to be merged points with only target dataset’s table relates. Any advice?  TIA

Reply
0 Kudos
5 Replies
Highlighted
Esri Esteemed Contributor

Hi Kathleen,

When you describe the two relationship classes, is the one with photos the attachments or another table that has attachments on it?  The latter may be harder to work through the append.

Reply
0 Kudos
Highlighted
New Contributor III

Hi James,

I wanted to get back to this question, as I am having the same issue again but with different feature classes. I have two feature classes, each one has two attachements with two relationship classes. THey are identical:  one fc titled allpoints, and two tables - allpoints_attach which is photos, and allstructures. 

I have tried to maintain attachments here, but no luck. Any suggestions?

Thank you!

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

What tool are you using to append the data together?

Reply
0 Kudos
Highlighted
New Contributor III

I am using the append tool. Does it matter that my foreign key is not

normally named? It is names “NewParentGUID”

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

That shouldn't matter so long as you are using the "NO_TEST" option and manually setting the field mapping (make sure all of the fields you want data to populate have an input field).

Reply
0 Kudos