last_edited_date not working in survey123

07-27-2022 01:16 AM
New Contributor III


I've seen that the last_edited_date field doesn't work in Survey123. It returns an error when publishing a survey. However, I was wondering if there is a workaround. So, I created a new field that contains the date & time (it's been already populated). The problem is that I want to use this new field to show in the survey the date of the previous check done but the same field is going to be used to update the same date. 

The field with the date is in the VehiclesCheck table. So I created another field in the main layer to copy the info of the date in VehiclesCheck to the new field.


I've already tried to use it but I get an empty result when using the survey.





Tags (1)
1 Reply
MVP Esteemed Contributor

Few things going on here I think.  First editor tracking is handled by AGOL not 123.  So the tracking fields do not get created until the form submits.  If you are using the inbox on a submitted form I am actually not sure if it will pull them down at all.

Second if you turn on editor tracking in ArcMap or Pro then publish you get last_edited_date.  But if you publish then turn on tracking in AGOL or publish a form right from 123 you get EditDate.  (Now why in the world they would have 2 different names?  No idea.  It used to be ETEdited back in the day.)

Go check the service and see which set of tracking fields you have then try that.  Then maybe you will get them in inbox but I am still not sure it will pull them.

Hope that helps