Issues with using .tpk in survey

72
2
01-14-2020 12:23 PM
SimonLange
New Contributor II

Hi all!

I am dealing with a problem where even after trying for multiple times and with different surveys, I seem to just not be able to use/ link a .tpk in my survey. I have tried adding the basemap both to the media folder and to ~/ArcGIS/My Surveys/Maps as well as linking it via the Connect App and manually via the .info file. So far without success. (Copying the basemap directly to the device is unfortunately no option for me.)

Could anybody please check the .info file? Or any other ideas on how I could solve the problem? Could there also be an issue with the basemap itself?

Thanks for any advise!

Greetings,

Simon

Reply
0 Kudos
2 Replies
DSIProvince_Nord
New Contributor III

Hi there,

If you put your tpk into the media folder, then the end user will have to download the survey and the tpk at the same time, which can be to heavy and long.

You should better add it via the form.info, then the user will DL the survey, and after choose whether he wants to DL the TPK in the Survey options.

Your .info file is not properly set up, please try the following :

Also note that you should enable "append" and "includeLibrary" parameters and also you want to add "defaultType" parameter so the tpk is always used at first, even if the user is connected to the internet (otherwise it will use online map instead)

And remember you have to close Survey123Connect to edit the form.info and then launch Connect to upload your survey.

{
"displayInfo": {
"map": {
"defaultType": {
"name": "BasemapLkrBamberg"
},
"mapTypes": {
"append": true,
"includeLibrary": true,
"mapSources": [
{
"name": "BasemapLkrBamberg",
"url": "http://uni-bamberg.maps.arcgis.com/home/item.html?id=dceb8b94ce7c4cfe8905e8c107cdc53f",
"storeInMapLibrary": false
}
]
},
"home": {
"latitude": 49.918889707453765,
"longitude": 10.856235446562152,
"zoomLevel": 16.0787
},
"includeDefaultMaps": false,
"preview": {
"coordinateFormat": "utmups",
"zoomLevel": 18
}
},
"style": {
"inputTextColor": "#00457D",
"textColor": "#00457D",
"toolbarBackgroundColor": "#00457D"
}
},
"imagesInfo": {
"captureResolution": 1280
},
"publishInfo": {
"connectVersion": "3.7.62",
"webFormTransform": false
},
"queryInfo": {
"applySpatialFilter": true,
"mode": "",
"where": ""
},
"sentInfo": {
"enabled": true
}
}

Reply
0 Kudos
DougBrowning
MVP Frequent Contributor

You can also copy it to the tablet manually then tell 123 where it is in settings.  At least I think that still works.

Not sure if you can do vector tiles yet?

Reply
0 Kudos