Intermittent "Scripts Disabled" message

371
4
07-01-2021 02:36 PM
Strahanjen
Occasional Contributor

I created a private survey for signed in organization users using Survey123 Connect version 3.12.232. To display a table of fish observations in a repeat, I use pulldata to run a javascript function that loops through the repeat array and returns a table. 

pulldata("@javascript","fish_functions.js","displayFishLists",${fish_entries})


This worked without issue for a few weeks and still works fine most of the time. However, last week several users reported intermittently seeing a message reading "Scripts disabled." I haven't yet been able to discern a pattern. Any suggestions on how to troubleshoot this intermittent issue? 

0 Kudos
4 Replies
DougBrowning
MVP Notable Contributor

Are they maybe getting timed out so they are not logged in anymore?  I have seen that.  Just a guess.  It seems to compare user name to the org.

0 Kudos
Strahanjen
Occasional Contributor

Thanks for the thought. I'll check. Is there anything that can be done to prevent the user from timing out? There are cases where they might have the fish survey open for several hours. 

0 Kudos
DougBrowning
MVP Notable Contributor

It should last 2 weeks if I remember right.  Other guess are they saving as draft and opening it back up?

0 Kudos
Strahanjen
Occasional Contributor

I just got more information from a user. The fish list script works fine for the first few hours of the survey and then "Scripts disabled" message appears. This does point to a time out. I wonder if there is any way that I can prevent the time out from occurring?