Installation error

274
4
Jump to solution
10-26-2018 03:11 PM
Highlighted
New Contributor III

I work for the government, on complex networked drives. On windows 10, when trying to install suvey123 or survey123 connect I get an error. It reads: Error during installation process (com.arcgis.appmake): Could not create link \\network location for ArcGIS.Ink:

I think because of this error, I cannot fire a survey on my desktop from AGOL using the URL. 

Does anyone know how I can overcome this?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
New Contributor III

Shobana, Thank you, you might have put your finger on the problem. I do not have admin access to my machine. I had our admin reinstall Survey123, and we confirmed it made that registry entry. However, when logged in as me it is not invoking that code. We think the issue is a security one, where trying to have an outside website (survey123) trigger an exe on my local machine, so I am not sure if I can get the admins to let this work. 

For now, I will focus on making it work on the web, which I am still having issue with if you see my other thread. Thank you.

View solution in original post

Reply
0 Kudos
4 Replies
Highlighted
Esri Esteemed Contributor

Hi Gregory,

Survey123, Survey123 Connect and other AppStudio apps currently do not support installation on a network share; they only support installation within a user's directory.

Reply
0 Kudos
Highlighted
New Contributor III

So my problem is deeper than that. The error I mentioned above I think is triggered when trying to put a shortcut on my networked desktop. That I can live without, and have installed survey123 on my local hard drive.

My REAL issue is I cannot get it to launch Survey123 from a custom popup in a Web Map. It worked fine on my old machine, which was windows 7, but I have a new machine on windows 10, and it will not open. I thought the error mentioned was the issue, but I don't think it is. The url is this:

https://survey123.arcgis.com/share/f8e8e75d2eae439f80625aba000b7d8c&field:PL_LCLTY_ID={GlobalID}?ope... 

When clicked, it opens the survey123 site, but it tells me to download survey123, which I already have on the machine, and it doesn't open my local copy of survey123. Everyone who has tried it on windows 10 here has the same issue. How do I overcome that?

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi Gregory,

Do you know if the logged in user has permission to create registry keys on the Windows 10 machine you're using?

Survey123 installer creates the registry key shown in below screenshot at the time of installation. This registry key is required for launching survey123 from url

Thanks

Shobana

Reply
0 Kudos
Highlighted
New Contributor III

Shobana, Thank you, you might have put your finger on the problem. I do not have admin access to my machine. I had our admin reinstall Survey123, and we confirmed it made that registry entry. However, when logged in as me it is not invoking that code. We think the issue is a security one, where trying to have an outside website (survey123) trigger an exe on my local machine, so I am not sure if I can get the admins to let this work. 

For now, I will focus on making it work on the web, which I am still having issue with if you see my other thread. Thank you.

View solution in original post

Reply
0 Kudos