How can I customize the labels of features in the inbox?

526
6
08-25-2017 02:23 PM
Highlighted
Occasional Contributor

I’ve created a form using an existing feature service.
I can see the features via the 'Inbox' in the field app, but the problem is that the labels - both in the list and on the map - are showing all of the features existing fields including the GlobalID. (See the attached screen shots)

How can I customize the feature labels so they will show specific fields only?

6 Replies
Highlighted
Esri Esteemed Contributor

Hi Ayelet,

The Instance Name - Instance name—Survey123 for ArcGIS | ArcGIS - controls the label of the feature.

Highlighted
Occasional Contributor

Thanks!

Reply
0 Kudos
Highlighted
New Contributor II

I am experiencing the same issue but editing the instance_name and republishing the survey does not change anything. Am I missing something? 
I created a form using an existing feature service. I open up Survey123, and open the inbox and the points have labels based on fields that I have not specified. I set the instance_names as ${business_name}


Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hello,

The label is controlled by the Instance name—Survey123 for ArcGIS | ArcGIS .

Reply
0 Kudos
Highlighted
New Contributor II

Hello James,

As mentioned above, I did add an instance name as $(business_name), and I created the survey using an existing feature service, and then downloaded those features when I opened Survey123. The inbox is what displays above. The article that you reference states "Survey123 for ArcGIS supports the instance_name setting in XLSForm. By using the instance_name setting, the author of the survey can control what information is used to uniquely identify every response in the lists of draft, outbox, and sent surveys."
So I am referring to the Inbox and "existing survey".

Reply
0 Kudos
Highlighted
New Contributor II

James, 
it is really strange, but when I posted yesterday, I was still seeing the problem, but today, (and coincidentally, I re-booted my phone earlier) and the inbox is now displaying correctly.

Reply
0 Kudos