High accuracy GNSS

892
10
12-09-2021 12:01 AM
Y_Chau
by
New Contributor III

Hello

I paired my android phone with a Ublox high accuracy receiver. While Field Maps shows proper accuracy numbers, Survey123 gets down to 3.9m and than stays there. Please advise on how to make RTK receivers supply and show proper accuracy readings in Survey123.

Sincerely

10 Replies
BertKraan1
Occasional Contributor III

Interesting, which ublox do you use? It's not whitelisted in https://doc.arcgis.com/en/collector-classic/ios/create-maps/gps-receiver-support.htm. Do you have supporting software for the ublox on your Android?

regards, Bert

0 Kudos
Y_Chau
by
New Contributor III

I use ZED-F9P based receiver with Bluetooth. I use an app called Lefebure NTRIP Client to route RTK via mock location. It works well with Field Maps.

Sincerely

0 Kudos
MarikaVertzonis
Esri Regular Contributor

In Survey123 have you chosen the Integrated Provider? When you are using an app to add RTK and then make that corrected position available to other apps via mock location, you need to have Survey123 configured to use the Integrated Provider (instead of connecting directly to it with bluetooth).

MarikaVertzonis_0-1639346370097.png

Some specific receiver hardware/software combo's do pass the corrected information from their app back to the receiver (some Eos Arrow's - not all I think), so that you can can connect to it via bluetooth and get the corrections, but this is not  common. 

Y_Chau
by
New Contributor III

Hi @MarikaVertzonis

I use integrated provider. Survey123 doesn't let me use Bluetooth. I tried on several devices but it pops same error.

Screenshot_20211213-091746.png

I get positions and corrections all good in the integration app called Lefebure NTRIP Client. All works fine with Field Maps as well. Only with Survey123 the reported accuracy gets stuck at 3.9m.

Sincerely

0 Kudos
FrederikPicavet
New Contributor II

Hi,

As a handheld we use a Panasonic FZ-N1 (android 8.1.0) with leica zeno connect (3.4.2.0.1850) and Survey 123 (3.13.244)  , and as a RTK we connect to Flepos .

 

* Now on the Leica FLX100, I get bluetooth metadata in S123

FrederikPicavet_0-1640012154615.png

 

* But on a Leica GG04 with same settings , no RTK data is coming in ,  or the bluetooth doesn't connect , or the Leica zeno connect app crashes .

8

FrederikPicavet_1-1640012265229.png

 

How can I solve this ?  The 2 type of receivers are recommended by you.

I have opened a ticket on the Leica side as well .... 

 

Thank you for the help

 

F

 

 

 

 

 

0 Kudos
FrederikPicavet
New Contributor II

I got feedback from Leica: The NMEA metadata is only forwarded by the 'GG04 plus' , ... we have the GG04, .... so this won't work . 

0 Kudos
igemetristechnologies
New Contributor II

Hello.
It's a little bit "special".
If I understand well, you have the good accuracy with Field Maps and not with Survey123.

I'm experiencing similar problems with Lefebure and Field maps, but on one device (android 11) I've the problem and on another (android 9) it's fine.
I thought it is related to device or android version, but if you have a different effect with two apps, it could be related to a setting, for example coordinate system?

Regards

0 Kudos
Y_Chau
by
New Contributor III

Hello

With help of Esri Support we could partly resolve this issue. The trick is to use Android Location and not Google Play Location. With some receivers S123 and QuickCapture are able to make the change from GPL to AL automatically. In QC you can do it manually by activating additional settings. This is done by holding down "About" for few seconds until "Reset" appears at the bottom. Then you will find this additional button in settings. After this it works smooth in QC. I tested on Android 8 and 10 with Lefebure and ArduSimple RTK GNSS. This workaround is yet to be implemented in S123.

Field Maps has no such option and we are yet to hear from support. FM behaves in 3 different ways:

  1. On Android 8 with location set as "High Accuracy" FM connects to ArduSimple via Lefebure but reports wrong accuracy. It is fixed at 3.9m. This is similar to QC if you use the default GPL settings.
  2. On Android 8 with location set as "Battery Saving" FM connects to ArduSimple via Lefebure but operates jerkily. It reports correct accuracy.
  3. On Android 10 There is no option to change location settings and FM fails to connect to ArduSimple via Lefebure.

As long as a receiver supplies NMEA, FM should be able to use it as does QC. Lefebure is a very stable app. I have tried it with few other receivers and it just works! Hope to hear from Esri soon. Will keep you posted.

Sincerely

0 Kudos
igemetristechnologies
New Contributor II

Hello.

Thanks for the feedback.

I hope you will get further help/answers from ESRI.

I make somes tries yesterday with Android 11 and I could nearly reproduce what you say with Android 8: accuracy is not fixed at 3.9m (it can be more), but never goes under.

If I install a third-party app (eg. from Trimble), the correct accuracy is detected, so I think this confirms that the problem is by FM, unfortunately. But somehow linked to NMEA used messages or integrated GPS/mock location..

Befause if I use some GNSS without NTRIP compatibility and use Lefebure, I'v this accuracy problem.
If I use an external GNN that includes SIM card and NTRIP correction, the accuracy is detected correctly by FM, then.

Regards

0 Kudos