Fixing the repeat records limitations in ArcGIS Enterprise

352
4
06-14-2020 01:03 PM
Hussam_AlJabri
Occasional Contributor III

Hi All,

James TedrickIsmael Chivite‌ @survey123

I'm designing a Smart Forms for many maintenance and operation activities in the organization and these forms contains a repeat questions captured the different assets details and photos.

I'm wondering if there is a timeline to fix the below limitationsin ArcGIS Enterprise while using Survey123:

 

  1. The attachment/images in the related tables (Repeat questions) dose not appear in Survey123 website (Data tap)  once we want to see single records. 
  2. The feature report not supported attachment.
  3. The attachments (out of repeats) are not associated to the questions in the data preview whereas they appear in the last of the report.

 

Regards, 

Tags (2)
0 Kudos
4 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Hussam,

Apologies for the delay in response.  Which version of ArcGIS Enterprise are you using?  Some of these have been addressed by later version of ArcGIS Enterprise

1. This sounds like an issue with queryAttachments, which is supported with ArcGIS Enterprise 10.8

2 & 3 are affected by the same issue. Having an image associated with a specific question requires ArcGIS Enterprise 10.8.1

0 Kudos
Hussam_AlJabri
Occasional Contributor III

Hi James,

Thanks for your respond.

>>1. This sounds like an issue with queryAttachments, which is supported with ArcGIS Enterprise 10.8

We are in 10.8 and still the only attachments appears which are related to the parent but those which are related to the repeat questions aren't appearing.

The below single records is containing two photos for the parent/point and many photos for the repeat.

>> 2 & 3 are affected by the same issue. Having an image associated with a specific question requires ArcGIS Enterprise 10.8.1

We are planning to upgrade by next week then I will check it.

Thanks

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Hussam,

A note on 2&3 - the attachmentKeywords (the property Survey123 uses to associate a question with a record) will only work for newly submitted data; additionally, support out of the box will be for hosted feature layers only.  You can enable support for attachmentKeywords for services that use enterprise geodatabases, but we are working on providing documentation on that procedure currently.

Hussam_AlJabri
Occasional Contributor III

Thanks James Tedrick

0 Kudos