Feature Report Error: Error: Cannot read property 'find' of undefined

09-28-2021 06:52 AM
New Contributor


When trying to create a new feature report I am receiving the error "Error: Cannot read property 'find' of undefined" after selecting my .docx to upload.

My feature reports were working before I changed the feature layer and submission URL that my survey is submitting too. 

I changed my feature layer because I had added a repeat to my survey, and I did not want to delete all of my data. The steps I took to do this are as follows:

1. Downloaded a FGDB of survey information, and added to a new map in ArcPro

2. Created a new table, created new fields, and created a new relationship with my feature layer. I then uploaded this to AGO.

3. I pointed the submission_url in Survey123 Connect .xls to my new feature layer.

After doing this my survey works, and all of my data/attachments are still viewable, but am unable to create a new feature report or when using an existing report I get a "An error occurred while generating reports." Any advise/help would be appreciated.


Tags (2)
0 Kudos
2 Replies
Esri Contributor

Hi @TylerDale,

I understood your requirement and tried to follow your steps, however, I can still successfully generate reports.

I'm curious can you successfully submit new responses to the survey with new submission url?

Are you seeing  the same generating feature report failure error for other surveys?


0 Kudos
New Contributor

Hi @alison_gou  and thanks for your response!

Yes I am able to submit a a new response to the survey with the new submission URL. With other Surveys that I have created I am able to run feature reports and do not get the same error.

0 Kudos