Failed to Submit. - Undefined: This operation is not supported.

831
5
Jump to solution
07-30-2019 06:55 AM
KevinChristy1
Occasional Contributor

Good day all.

I created a survey in the Survey123 App on AGOL (using Chrome as the browser). I have shared my survey with the public and have been creating some test entries. I have been getting the above error when I try to submit a survey BUT it only occurs when I use a browser other than Chrome.

Chrome: the survey submits without issue and the corresponding feature layer is updated.

Safari, IE, Edge, Firefox: No bueno, I get the above error.

I just edited some of the survey entries before doing this testing, so I am going to create a new test survey and try it again to see if that may be part of the issue. I will update this thread.

Any help would be appreciated.

Kevin

0 Kudos
1 Solution

Accepted Solutions
KevinChristy1
Occasional Contributor

Good day Brandon!

So the error message is the title of the post verbatim. I found that some settings of the survey were grayed out and I was getting an error message when trying to update and of the sharing settings. I fixed this issue by simply creating a copy of the survey and republishing it. Everything then worked as it should, leading me to believe it was some sort of bug.

Kevin

View solution in original post

0 Kudos
5 Replies
BrandonArmstrong
Esri Regular Contributor

Hi Kevin,

I believe that you forgot to include the error message in the post.  If the survey is still public, please provide the share url to the survey with me in a private message on GeoNet so that I can test.

Best,

Brandon

0 Kudos
KevinChristy1
Occasional Contributor

Good day Brandon!

So the error message is the title of the post verbatim. I found that some settings of the survey were grayed out and I was getting an error message when trying to update and of the sharing settings. I fixed this issue by simply creating a copy of the survey and republishing it. Everything then worked as it should, leading me to believe it was some sort of bug.

Kevin

View solution in original post

0 Kudos
BrandonArmstrong
Esri Regular Contributor

Thanks for the update, Kevin.

We do not have record of this specific error or behavior occurring in the past, but if you encounter it again please let us know so that we can take a further look with you.  It almost seems like credentials were cached in Google Chrome which was allowing you to send the survey, while the others were honoring share settings that had been changed.  In any case, please let us know again if this issue occurs in the future, or contact our Technical Support to take a closer look.

Best,

Brandon

0 Kudos
MarianneLindau_Langhelle
New Contributor II

I am now having the same problem with a survey created a while back. https://survey123.arcgis.com/share/536b5017ae32411e961812ab38b6a2d6 

When I attempt to submit an answer without being logged in, I get the error message: "-undefined: this operation is not supported". At first I also thoughts it was an issue with browsers besides Chrome, but when I tried in a Chrome browser where I wasn't logged into ArcGIS Online, I got the error message there as well. The survey is shared with everyone. 

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Marianne,

In looking at the feature service view tied to your survey, I see that editing operations are not allowed (the capabilities list only shows Query and Sync).  This would prevent submissions from being able to occur.  See either Share survey—Survey123 for ArcGIS | Documentation or Manage hosted feature layers—ArcGIS Online Help | ArcGIS to update the fieldworker view of your form.