Extracting Survey123 Data from Device

684
2
05-14-2019 07:46 AM
SusieSaliola
Esri Contributor

I am working with a client that is having issues with uploading their surveys. They created a survey using Connect, and somewhere along the way something has gone awry. When they try to Send the collected data from the tablets, the app gets stuck on "Getting service information". I looked online, and there is an error on their survey saying, "The survey is broken. Cannot get source feature service info from formInfo file. Cannot get an feature service info (including source, fieldworker, or stakeholder views)." 

I have attempted the steps outlined in this post about Recovering data from a mobile device, by saving the .sqlite file onto my computer and then using DB Browser and a desktop version of the field app to upload the surveys. One of the surveys showed up in the outbox - unfortunately upon sending, the desktop field app also gets stuck on "Getting service information"

Is there another way to extract the data off of the device in any format? The last relevant posts are from 2017.

0 Kudos
2 Replies
SusieSaliola
Esri Contributor

Update:

I tried to use the script from this post Importing Survey123 SQLite Database from Device, which worked for one .sqlite file, but for the other 3 gave me an error "cursor.insertRow(row) RuntimeError: The row contains a bad value".

I decided to use Connect to create an exact replica of the corrupted survey. I then used the steps outlined in Recovering data from a mobile device, to change the Path of each .sqlite file to point to the ID and Name of the newly created survey. I was then able to use the desktop version of the field app to upload the surveys one at a time to a new feature service. 

0 Kudos
BrandonArmstrong
Esri Regular Contributor

Hi Susie,

One thing that would be helpful in attempting to diagnose the cause of the issue would be to capture a log (to file) of the behavior at the time of survey submission.  The steps in the documentation linked below explain how to do this.  If you are able to grab the log, and are also able to upload it to this thread, we would be able to investigate the cause a bit further.

Survey123 Field App - Capture Error Log

In them meantime, it looks like you found a method to workaround the issue.

Best,

Brandon

0 Kudos