Displaying data from a second geopoint question on a webmap

333
1
Jump to solution
12-07-2020 11:25 AM
Marie-LouLabuschagne
New Contributor III

I created a survey with Survey123 Connect version 3.11.123 and successfully added two geopoint questions.  I use pulldata @geopoint to extract the x & y coordinates for each question.  The survey functions perfectly, and I have records with coordinates for the first question, and records with coordinates for the second question (where the values for the first question is 0).

The records captured with the first geopoint display on a map, but the records with the second geopoint doesn't display.

How do I display these second geopoint records on a webmap, so that my users can see pop-ups for all the data collected?  I don't mind displaying the records as two different layers on the map - just need to know how to get the web map to "create" the point based on the second geopoint values....

 

0 Kudos
1 Solution

Accepted Solutions
Philip-Wilson
Esri Notable Contributor

Hi Marie-Lou,

A feature layer can only have one geometry, so the points displayed on the web map will be from your first geopoint which is the geopoint that is recording the geometry for the layer.

For the second geopoint, I assume you have set the bind::esri:fieldType to "null" which means that the geometry is not being recorded, and you are using calculations to pull the lat and long into text fields via pulldata() calculations. To display those points on the web map you would need to create a new layer where those points are used as the geometry. You can do this from ArcGIS Online or Pro. Once a layer is created that is using these points as the geometry, you can add that layer to the web map.

Regards,

Phil.

View solution in original post

1 Reply
Philip-Wilson
Esri Notable Contributor

Hi Marie-Lou,

A feature layer can only have one geometry, so the points displayed on the web map will be from your first geopoint which is the geopoint that is recording the geometry for the layer.

For the second geopoint, I assume you have set the bind::esri:fieldType to "null" which means that the geometry is not being recorded, and you are using calculations to pull the lat and long into text fields via pulldata() calculations. To display those points on the web map you would need to create a new layer where those points are used as the geometry. You can do this from ArcGIS Online or Pro. Once a layer is created that is using these points as the geometry, you can add that layer to the web map.

Regards,

Phil.