Date/Time error now in web version only

343
3
11-24-2021 11:26 AM
by Anonymous User
Not applicable

I have a Survey123 built in Connect that we've been using for 6 months.  It's mostly used on mobile device, but some folks use the webversion to back enter records.  Starting sometime with the last month, the Date and Time field are throwing an error:

"Operand type clash: bigint is incompatible with datetime2"

I've tried entering various dates and times to no avail.

I found one post that suggested changing the web setting to always use the latest version.  I did change that but we were using the latest version already so that did nothing.

 

Update, I have a second date/time field (for the Excel non-UTC aware) that uses this calculation behind the scenes. It seems my issue is related to this since when I remove that field & calculation I get no errors.

${EventDateTime} + pulldata("@property", "utcoffset")*1000*60*60

I have changed my web to use the latest version, I checked that I have version 3.13 for Connect, and I have republished the survey.

I thought that the pull data and @ property is supported in web now?

 

Any ideas?

 

3 Replies
alison_gou
Esri Contributor

Hi @Anonymous User ,

I tried to reproduce your issue but I failed to encounter the same issue, my second question in web app ends up empty. Can you share one xls form so I can reproduce this issue?

Regards,

Alison

0 Kudos
by Anonymous User
Not applicable

Hi Alison,

Sure thing, I attached it here.  

Thanks!

0 Kudos
BritaLauraĀbelkoka
New Contributor

Hi, 

I have the same problem: I have a dateTime question, where I get UTC value, then there is a calculate question with field type set to esriFieldTypeDate. Works fine with field app, web form returns same error when submitted.  

0 Kudos