Created Survey123 form from .xls file, published with webform on, can't open in browser. What am I missing?

510
3
04-03-2020 11:23 AM
AmyBrassieur
New Contributor III

The browser says it can't find the .webform file. I re-published the form, carefully checked the options, web form was turned on.  It works fine in the Survey 123 app but I need it to work in a browser for public access. I've tried Edge, Opera and Chrome browsers, same error.

Tags (1)
0 Kudos
3 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Amy,

There are few points you can check here:

1. What version of Connect did you use to publish? I noticed that you have 1.1 specified in Setting tab in your xls form. You might want to remove it and use the latest Connect to publish the survey again.

2. On survey123 website, click your survey and check Collaborate tab and make sure you choose first or second option to have user open the survey from browser or an option to choose from browser or field app.

AmyBrassieur
New Contributor III

Thanks, that's the trick! I had obtained the spreadsheet from our state OHSEP, I think they meant that version number for their customization tracking, not to specify what version of Survey 123 to use. Now I know what that field is really for!  Now it's working in a browser!

Thanks again!

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Amy,

Just to clarify the Version column in the xls form and you are correct that the version number is for the survey's version, not the Survey123 version:

Settings—Survey123 for ArcGIS | Documentation 

It might be using the latest Connect to publish the survey correct the web form issue, but not by removing the 1.1 from the Version column though.

0 Kudos