Create Feature Report Empty

134
6
03-20-2020 11:46 AM
DebraCrouse
New Contributor II

I am trying to use Survey123 and Integromat and have followed all of the directions, side by side with the tutorials. When I run the scenario there is something wrong with the Create Feature Report that comes up empty so the HTTP module throws an error.

Integromat support just tells me "Is not being returned, therefore is empty and that's why you get the error, you don't get any url in the response. Sometimes the variables that the module shows that it returns, it's greater to the actual variables that you would get since sometimes depending on the use case it might return a part of the variables that it shows as mappable, which is the case here."

Not sure what that means.

Thanks,

Debby C

0 Kudos
6 Replies
BenTurrell
Occasional Contributor III

Hey Debra Crouse‌,

Can you send me a link to the tutorial so I can have a look? From your screen shot it looks like you need to put a url into this field:

I'm guessing this is where the issue is!

Thanks,

Ben


If this answer was helpful please mark it as helpful. If this answer solved your question please mark it as the answer to help others who have the same question.

0 Kudos
DebraCrouse
New Contributor II

Hi Ben,

Here is a link to the tutorial. https://community.esri.com/groups/survey123/blog/2019/06/04/survey123-tricks-of-the-trade-integromat 

I thought it automatically put in the url, so it maps it:  resultInfo: resultFiles(): url

It is the Create Feature Report that is empty.

Thanks,

Debby

0 Kudos
BenTurrell
Occasional Contributor III

Debra Crouse‌,

I haven't seen that tutorial before. I'll have a play with it tomorrow and let you know how it goes!

Thanks

Ben

JamesTedrick
Esri Esteemed Contributor

Hi Debra,

Looking at the results, the report template job failed (note the jobStatus in the output), therefore there is no report to download.  You would want to filter the HTTP get a file request based on that status so the workflow can end without error; additionally, you might want to look at the jobStatusInfo details to determine why it failed.

0 Kudos
DebraCrouse
New Contributor II

Hi James,

I am not following. I get that there is no report, but why? How do I fix that? 

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Debra,

As I mentioned, the jobStatusInfo should provide details about why the job failed.  

0 Kudos