checkbox output on feature report from select multiple

917
8
12-06-2019 01:38 PM
MikeOnzay
Regular Contributor

I'm having problems getting past the syntax test when uploading a feature report template. I created a new template from S123. I'm changing one select_multiple question to try out the examples in my own survey from the help guide.

${facility_type} is the original and it works. The output is full,carry_out

Trying

${facility_type | selected:"full"} Full - (Why do I need to include the word Full outside of the curly brackets? Is it a label?)

Error: Failed to parse ${facility_type|selected:”full”}. Filter selected:”full” is not supported."

or

${facility_type|appearance:"bullets"}

Error: Failed to parse ${facility_type|appearance:"bullets"}. Filter appearance:"bullets" is not supported."

0 Kudos
8 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Mike,

It might be helpful to see the full template; given the error message, I'm wondering if there is a slight formatting issue before that is causing the template to be mis-parsed.  

To answer Why do I need to include the word Full outside of the curly brackets? Is it a label? - yes, in that case it is a label - the placeholder will show a checked or empty box.

0 Kudos
MikeOnzay
Regular Contributor

Here you go. I'm not changing anything else on the document I download except for that one line.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Mike,

Yes, the word file doesn't look very complicated.  That being said, there are some aspects that look a little unusual - there are several questions that look like they are notes but seem to have values.  Could you share the form with my user (jtedrick_survey123)?

0 Kudos
MikeOnzay
Regular Contributor

I shared the form through a group called ESRI Incident that I invited you to join.

0 Kudos
MikeOnzay
Regular Contributor

I shared the wrong form template with you. I've now shared all of the relevant items to the group I invited to you too. I included the original template generated from Manage templates and a modified template with

${facility_type|appearance:"bullets"} in it, that fails the syntax check when I try to upload it.

It is true that I have note fields in the survey because the person who does the inspections is always the same.

I can also open an formal ESRI incident request if that would help.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Mike,

I'm not finding anything particular at issue. If you could transfer this to Esri Support for further troubleshooting, that would be helpful.

0 Kudos
MikeOnzay
Regular Contributor

I created a small form for testing. My results show that including ${select_multiple | countSelected} never gets past the syntax check when uploading the file. I was using ${sample1 | countSelected}. I do have an open case and the tech support analyst had the same result.

Does using countSelected work? Can you show me example of the expected output?

I was able to see other results with the test form.

I had expected that the appearance:"bullets" filter would show dots and instead it showed a numbered list. Maybe the documentation can be updated to be more clear?

The select_one question (asset) had an answer of either yes or no

The select_multiple question (sample1) had the following choices: red, blue, yellow

 

Input:

${asset|selected:”yes”} Yes

${asset|selected:”no”} No

Output:

  Yes

  No

Input: 

List all favorite colors 3

${sample1 | selected:"red"} red

${sample1 | selected:"blue"} blue

${sample1 | selected:"yellow"} yellow

Output:

List all favorite colors 3

  red

  blue

  yellow

Input: 

List all favorite colors 4

${sample1|appearance:"bullets"}

Output:

List all favorite colors 4

  1. red
  2. blue
0 Kudos
MikeOnzay
Regular Contributor

Looking back at my original form questions I wondered if the field, facility_type, was throwing an error because it is a hidden question type. When I changed the facility_type_temp to an ESRI Type of esriFieldTypeString, republished and uploaded the test template then it passed the syntax check.

Even though the hidden question type had an ESRI Type of esriFieldTypeString it appears that the template requires the question type to be a select_mutliple question type.

Now the question is how to make the pattern of "other" work...

By the way

${facility_type_temp | countSelected} still failed the syntax check

Error: Failed to parse ${facility_type_temp | countSelected}.

0 Kudos