Certain Survey123 surveys not submitting when webhooks are turned on

01-29-2021 12:18 PM
New Contributor III

I have an older feature service that is populated with a Survey123 field survey and I've been trying to set up a webhook to trigger a workflow in FME when new surveys are submitted or old survey data is edited.  I tried to run the webhook through Survey123's built-in webhooks, but my workflow requires that I update the itemsets.csv often for the Survey and every time I update that itemsets.csv file in the form through the ArcGIS API for Python. 

So I've been trying to use the new webhooks function through the REST of the feature service, which I can get to work just fine with new Surveys.  When I create a webhook for the feature service of a slightly complex survey (created in Survey123 Connect), the survey gives me a "Send Error: Surveys not sent."  When I turn off the webhook, the survey data is instantly submitted (with as many copies of the survey as I tried to submit when the webhook was on).  The same happens when I create a view of the feature service, then create a new identical survey from the view of the original feature service.

Has anyone else had this problem? @JamesTedrick can you help me with this?

I have attached a copy of the log file from Survey123 (errror was at 2021-01-29T19:25:49Z) and the Survey123 XLS file. I am using Survey123 Connect Version 3.11.123.

0 Kudos
0 Replies