Cannot link a CSV file in Media folder to the survey (v 3.14 and 3.16)

623
6
01-30-2023 09:33 AM
KerryKang
Occasional Contributor III

Hi, 

I have a survey that pull out x, y coordinates from the csv stored within the media folder. It was published at least 3.14 or earlier version and it's been working fine until I update the survey with 3.16.

 

The error I realized was that it does not pick up known x, y location and turned out there is no linkage between the CSV and the survey. I tried to add the CSV back, but it looks like there is no option for me to add the actual csv file from the media folder.

 

I re-downloaded version3.14 but it still does not give me an option to add the csv file directly. This affect an important app used by multiple organizations. 

Thanks.

KerryKang_0-1675099822528.png

 

0 Kudos
6 Replies
DougBrowning
MVP Esteemed Contributor

You need to add the CSV as an AGOL item and then you link to that.

Hope that helps

0 Kudos
KerryKang
Occasional Contributor III

Thank you @DougBrowning . It's too bad that the media folder option for csv is not valid anymore. Do you know if it would still work during offline?

 

Kerry

0 Kudos
DougBrowning
MVP Esteemed Contributor

Yes it works offline.  You can still also use the media folder.  I thought you meant linked content.  Two different things.

0 Kudos
IsmaelChivite
Esri Notable Contributor

@KerryKang  This is worth exploring in more detail. As @DougBrowning described, you can optionally link your CSV file, but you do not have to. A CSV file hosted in the media folder should work well in 3.16.

All you need to do is to copy the file in the media folder. I am not sure what you mean by "I tried to add the CSV back, but it looks like there is no option for me to add the actual csv file from the media folder". Really, all you do, is to copy the file into the folder.

KerryKang
Occasional Contributor III

@IsmaelChivite  Thank you for your comments. I already have the x,y csv file in the media folder (I did not see 'media' tab next to 'linked content'. However it looks like it cannot pick up x, y values from the csv to create a point (see the image below). This error shows across any browsers that I am using, Edge, Chrome in both regular and private versions.

 

There is no change in the csv file other than updating a couple of attributes that won't affect in the workflow. Any suggestions?

 

Thank you. 

 

Kerry

KerryKang_0-1675118710664.png

 

0 Kudos
KerryKang
Occasional Contributor III

@IsmaelChivite 

 

I actually could fix it by republishing it again through 3.14. There were multiple csv files that I kept as archive and I was wondering they might interfere with the functionality. The weird error message above 'Can not find your location. Please check your browser to ensure that your location is shared' was gone after cleaned up the media folder and republished in 3.14. However, when I republished the survey through 3.16, the error came back. Can I get more information why I experience this behaviour?

Kerry

 

Image of the survey when published through 3.14 (no error).

KerryKang_0-1675120553245.png

 

0 Kudos