Can a Report grab Geometry form another related layer?

08-09-2022 02:59 PM
MVP Honored Contributor

I have tried several different ways but I cannot get this to go.  Not sure it is possible.

I have a layer in my map that holds all my geometry that is related to the 123 form as a child.  It is not part of form and it does not use GlobalIDs for the relate - it uses a text field.

123 does see the layer is related and it does add it to my report map.


I tried a more complicated query but it did not work.  So I tried a simple one and still no go.

${#PFCPoints} ${FormID} ${/}   - I get nothing

I tried adding a query and nothing

${#PFCPoints | where:"FormID='0ADB4682-5900-4278-AFEE-63C072AAEC3F'"} ${FormID}${/}

I will need to use the FormID to call which I think would look like this

${#PFCPoints | where:"FormID=${FormID}"} ${FormID}${/}

But what I really want is a map from the other layer and this does not work - gives an error.

${#PFCPoints | where:"FormID=${FormID}"}  $shape ${/}


In the end I want the report to go grab the geometry from a different layer (that is not in the form) and add a map to my report.

Is this possible?

thanks a lot

0 Kudos
1 Reply
MVP Honored Contributor

Well after hours of testing the where clause it seems like I do not even need it?

It is somehow selecting my feature in the other layer and giving a highlight just doing this.  I am not sure how it is figuring out what to highlight.  At least I think its a highlight I wonder if it is just zooming to the form location and I get lucky.

${#PFCLines} ${$shape | mapSettings:"736a28d9da6cdc838d10100540":40000 | size:400:300} ${/}


But ideally I would like to show Only the feature highlighted. And not show the non highlighted here.

Adding a where clause and I get no map displayed at all.  (I think I finally figured out that syntax from this page )

${#PFCPoints} ${$shape | where:"FormID='"+FormID+"'" | mapSettings:"736a28d9da6c46faa4dc838d10100540":50000 | size:400:300} ${/}

Note sure if it is a syntax issue or it is not using the FormID from the form.  Not many examples of this so I am not sure.  I get no map at all so it could be syntax.

But even if a hardcode a ID I still get no map.  I am not even sure which layer it runs the query on - help does not say.  

${#PFCPoints} ${$shape | where:"FormID='3741C9F6-342C-42CC-BCCA-6E888E354D2'" | mapSettings:"736a28d9da68838d10100540":50000 | size:400:300} ${/}

I have tried other fields also.  It seems that when I give it a where clause it gives me no map.

At this point I am pretty lost in what where does.  The whole syntax is kinda confusing.

Anyone have any examples?


0 Kudos