autorefresh url parameter not working for public survey with web browser on portal

284
2
Jump to solution
02-17-2024 10:58 AM
LS1
by
New Contributor III

I have a public survey created by Survey123 connect 3.19.104 for use on web browser. Our organization uses portal.
The survey works fine using a web browser: 
https://survey123.arcgis.com/share/535b6167dade4443a2734bbdca6efab1?portalUrl=https://gis-portal.xxx...

but when I try to append the autorefresh parameter at the end of the url
https://survey123.arcgis.com/share/535b6167dade4443a2734bbdca6efab1?portalUrl=https://gis-portal.xxx...?autoRefresh=true

I receive an error message "The survey is not accessible or does not exist."

Help?

 

0 Kudos
1 Solution

Accepted Solutions
IsmaelChivite
Esri Notable Contributor

Hi. I think the problem is in the URL:

This is not correct: https://survey123.arcgis.com/share/535b6167dade4443a2734bbdca6efab1?portalUrl=https://gis-portal.xxx...?autoRefresh=true

This is correct: https://survey123.arcgis.com/share/535b6167dade4443a2734bbdca6efab1?portalUrl=https://gis-portal.xxx...autoRefresh=true

Note that right before autoRefresh I replaced ? with &

By the way, I think you could give this a go as well:

  1. Remove the autoRefresh parameter from the URL
  2. Instead:
    • Go into survey123.arcgis.com and click on your survey
    • Open the Design tab
    • Click on Options
    • Set the auto-refresh policy (you can choose 0 seconds if you like)
    • Publish

 

AutoRefresh.gif

 

View solution in original post

0 Kudos
2 Replies
IsmaelChivite
Esri Notable Contributor

Hi. I think the problem is in the URL:

This is not correct: https://survey123.arcgis.com/share/535b6167dade4443a2734bbdca6efab1?portalUrl=https://gis-portal.xxx...?autoRefresh=true

This is correct: https://survey123.arcgis.com/share/535b6167dade4443a2734bbdca6efab1?portalUrl=https://gis-portal.xxx...autoRefresh=true

Note that right before autoRefresh I replaced ? with &

By the way, I think you could give this a go as well:

  1. Remove the autoRefresh parameter from the URL
  2. Instead:
    • Go into survey123.arcgis.com and click on your survey
    • Open the Design tab
    • Click on Options
    • Set the auto-refresh policy (you can choose 0 seconds if you like)
    • Publish

 

AutoRefresh.gif

 

0 Kudos
LS1
by
New Contributor III

Thank you @IsmaelChivite. Reading is fundamental!  I scanned this page quickly for the parameter but didn't read the section above it when there are multiple parameters. Thank you for the quick response! 

0 Kudos