Appstudio template

101
3
03-28-2019 07:38 AM
Highlighted
New Contributor

Hi!

We have created our own version of Survey123 with Appstudio based on the template that matches version 3.3. Unfortunately, this version is not working for us. Is there any way to get an older version of the Survey123-template then the one in Appstudio? (Not as old as classic 2.8 though). Preferably one based onAppFramework-version: 3.1.106.

Reply
0 Kudos
3 Replies
Highlighted
Esri Frequent Contributor

Hi Patric,

What version of AppStudio are you using? The Survey123 template has to match the AppStudio version it is designed for, that is why in the enterprise template gallery you only see the version that is compatible.

If you want to use a Survey123 3.2, 3.1 or 3.0 version template you will need to use an older version of AppStudio that matches that version.

Phil.

Reply
0 Kudos
Highlighted
New Contributor

Hi Philip!

Thanks for the response. I have tried AppStudio version 3.0.53 which only contains the template for Survey123 version 2.8. The next version available, 3.1.134 contains the template for version 3.3 and 2.8. Same goes for the new AppStudio 3.2.79.

What we are looking for is a template matching version 3.0.149 or prior to version 3.3

Med vänlig hälsning

Patric Wiström

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi Patric,

I have checked with the AppStudio team and discussed internally. Basically the short is that we only provide the latest Survey123 template (for the latest released version) which must be used with the latest version of AppStudio. There are several reasons behind this due to the minimum requirements and dependencies between the versions.

Therefore if you want to use the Survey123 latest template to build your own custom build, you will need to upgrade to latest version of AppStudio. We do not make older version of Survey123 template available once the new version of AppStudio is available.

Regards,

Phil.

Reply
0 Kudos