After Update 3.0 got Error Feature service requirements not met and in other version works fine

1190
5
07-10-2018 08:13 AM
DiegoLlamas
Occasional Contributor III

Hello,

We have several Surveys created hosted in Portal 10.6, we were working fine with the configuration we have set until version 2.9.5 Once Survey for ArcGIS in our iPads update survey app automatically for Survey 3.0 and in that version we are getting error 

and SupportsApplyEditswith GlobalIDs is set to true

And with version 2.9.5 is working fine I was able to send the info

I am not able to downgrade my app from the iPads, how can I solved this this new version, is it supported for this version? @james tedrick

Thanks, 

Diego Llamas

5 Replies
FiorellaRodriguez
New Contributor III

I´m having the exact same problem after the installation of survey123 v3.0. 

0 Kudos
ChrisRoberts2
Occasional Contributor II

As per another post (look to the very end of the thread):

Feature Layers and supportsApplyEditsWithGlobalIds: Starting with version 3.0 you will no longer be able to submit surveys or publish/republish a survey against a feature service that does not have the supportsApplyEditsWithGlobalIds property set to true. While this requirement is not new, we previously only enforced it for surveys with repeats. It is therefore possible that your existing ArcGIS Online or ArcGIS Enterprise feature services don’t have this capability– so please check them to ensure that they will work when you update. The easiest way to enable this property is to simply enable the sync capability (Synchronization) on your feature service. Please follow instructions in the Allow offline editing or collaboration section of the Manage hosted feature layers—ArcGIS Online Help | ArcGIS help topic for details on how to enable the sync capability.  If working with ArcGIS Server, remember that you cannot turn on sync if your data is versioned or if your layer lacks an indexed GlobalID field.

https://community.esri.com/message/752500-re-survey-publishing-error-supportsapplyeditswithglobalids... 

I my particular case I am using layers from our Enterprise Geodatabase so to fix this I needed to do the following:

  1. Enable archiving on the layer in the SDE
  2. Republish the service with sync enabled
  3. Republish the Survey from Survey123 Connect
  4. Delete the existing survey on the Device and logout of Survey123
  5. Hard reset the Device, there was some sort Cache thing going on
  6. Open Survey123 on the device, login in and re-download the survey
DiegoLlamas
Occasional Contributor III

Hello Chris, I was able to bypass the error enabling archiving on the database for the layer i was using and republishing the service. Thank you very much for your help!

Philip-Wilson
Esri Frequent Contributor

Hi Diego,

To recover unsent surveys from iOS devices you can follow these instructions found in the Survey123 help documentation: Troubleshoot—Survey123 for ArcGIS | ArcGIS 

If you are using Android or Windows, we have Survey123 Classic 2.9 version available which will work with your services, currently in app stores and on the Survey123 download page. If you are using iOS please make contact with me via private message and we may be able to get a beta version of the Survey123 Classic app for iOS available to you.

Phil.

Anish_Adhikari
Occasional Contributor

Hi Philip,

I am having the same problem on IOS. I am using standalone SQL without SDE(We do not have enterprise license) so there is not any way for me to set the applyeditswithglobalids to true on my feature service. How can I get the beta version of Survey123 Classic app on iOS?

0 Kudos