499 Publishing Error: Bad Gateway

85
3
10-20-2020 10:11 AM
Highlighted
New Contributor

I have been using this survey for 2+ years, and updating it frequently, without issue. I went to add a new choice for a question on the 'USE THIS VERSION' sheet as well as a row on the 'courseexternal' sheet and now I can't publish. I attached a screenshot of the error I got. Its error code 499. I've tried removing the data I added and still can't publish, even though I have published that same exact survey before. 

Tags (2)
3 Replies
Highlighted
New Contributor III

I have the exact same issue - It's a survey I've had for years, it's actively being used, and I just tried to add new choices to a dropdown list. Error 499: Bad Gateway. I've tried now for 3 days in a row to publish and gotten the error every time. 

Hoping that esri has an answer for this!

Reply
0 Kudos
Highlighted
New Contributor III

I figured I'd provide an update: my publishing error (499 Bad Gateway) seemed to be entirely related to the version of Survey123 Connect I was running. I just updated to version 3.9.120 and that instantly solved my publishing issue. So that may be worth a try for others who are experiencing the same. 

Highlighted
New Contributor II

Thank you @MegTracy ! It actually worked !!!

Reply
0 Kudos