Minimum field app version requirement

142
1
07-25-2017 01:46 PM
Status: Implemented
BradenBurkholder
Occasional Contributor

In Survey123, users may try to fill a survey in an older version of the field app that is not compatible (due enhancements or bug fixes), resulting in lost or uncollected data, or survey submission failure. It would be great if a survey developer could specify the minimum version of the field app that is able to run a survey. A simple notice to update the app could be thrown if a user downloaded the survey that was incompatible. The minimum field app version could be stored in the settings worksheet.

1 Comment
JamesTedrick
Status changed to: Implemented

pulldata('@property', 'appversion) is now an available option to retrieve the app version, which can then be used in a constraint. Please refer to 'Prepopulate answers' documentation for more details.