Popup settings on original map are not applying to the storymap.

987
11
08-30-2019 01:58 PM
DustinSchiffer
New Contributor

I have a map I have created with multiple layers, one of them being a roads layer. I only need the labels, so I set the lines to transparent, as I usually do in Pro. I disable popups for the roads layer, which applies correctly to the map. When I go to the Story Map, the popups are still enabled. I have done everything from creating an entirely new map and starting over on the Story Map, but the issue keeps occurring. I also noticed that the drawing orders aren't applying. This issue wouldn't be a huge deal, but the popups keep putting the roads layer first in the popup, even though it is last in drawing order. The only somewhat acceptable thing I've done now is to just enable popups but remove all attributes, so atleast it is a blank popup that the user can scroll to the next relevant page. I have redone everything multiple times, so I believe this is a bug. I also noticed other settings will... unapply?... after the Story Map has been open for a decent amount of time. By this, I mean for the first 10 minutes all of the roads will be transparent, as intended, then randomly it will give the roads a white color and remove transparency. That is a secondary issue, though.

Tags (1)
11 Replies
OwenGeo
Esri Notable Contributor

Dustin -- Sorry you are having trouble getting your map to behave the way you want in your story. Can you share a link to the web map here so we can take a look?

If you're not able to share the map publicly, please contact Esri Support and they can help you troubleshoot.

Owen Evans
Lead Product Engineer | StoryMaps
hgaignard
Esri Contributor

Same issues about layer's transparency and pops-up are not respected in ArcGIS StoryMaps.

  • In Map Viewer, transparency on the "Zones" layer and pop-up disabled on the "Parcours" layer :

But in ArcGIS StoryMaps, these parameters are not respected

However, the transparency of the "Pays" layer is well respected.

And I noticed that when I refresh the Story on the map where the transparency is not respected, it applies after the refresh. But if I open the Story in a new tab, this issue starts again.

hgaignard
Esri Contributor

I discovered that my transparency issue appears when I use the same web map (on a different extent) in a series of sildes in a sidecar block.

If I save a copy of the web map and then I alternate original web map (slide 1) then its copy (slide 2) then original web map (slide 3) then its copy (slide 4). 

The map transitions are no longer pans but fades because web map change to each slide = no more transparency problem.

SamaraEbinger
New Contributor

I am having the same problem with the popup issue above. I've created a new story map and embedded several web maps. For two of my maps (this one and this one), popups show up for every visible layer in the story map despite popups for these layers being disabled in the web map. Is there any workaround for this?

0 Kudos
OwenGeo
Esri Notable Contributor

Samara Ebinger‌ / Dustin Schiffer‌ - We made some changes to address this issue. Please test your web maps again and let me know if the pop-ups are still showing in the story when disabled in the web map. Samara, I tested the ones you provided and they seemed to be working as expected.

Owen Evans
Lead Product Engineer | StoryMaps
SamaraEbinger
New Contributor

I tested mine and they are working correctly now - thanks! Samara

ErinCourtney1
New Contributor

I am having a pop-up functionality issue as well. In my web map the pop-up is configured appropriately, but in my StoryMap it is pulling the wrong information. It is not pulling from the field I have it set to, it is instead putting the name of the layer in the web map. HELP!!

This is what it looks like in the web map: (Correct)

This is what shows in the StoryMap:

0 Kudos
OwenGeo
Esri Notable Contributor

Hi Erin -- Can you try opening up your web map in the beta map viewer (and/or share your web map here so we can take a look)? The map viewer beta uses the same 4.x version of the ArcGIS JavaScript API as ArcGIS StoryMaps (whereas the standard map viewer uses the 3.x JSAPI). There shouldn't be anything different that we do in story maps to make the pop-up content different, so I'm wondering if this is a JSAPI issue.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
ErinCourtney1
New Contributor

Hi Owen,

When I opened it in the beta map viewer I encountered the same problem. Seems like you are correct with the JSAPI diagnosis! Is there a solution? For now I can do a fairly easy work around in the pop-up configuration. Thanks!

If you need me to, I can share the map  for further diagnosis.

0 Kudos