new version of story maps not working on Firefox

377
5
12-14-2021 05:54 AM
RobinConner
New Contributor II

Hello.  Up until last week, the new version of Story Maps (not the classic version) was displaying on Firefox fine.  After the AWS outage, new Story Maps no longer displays in Firefox.  All that comes up is a blank screen with the title of the Story Map in the title bar at the top.  Classic version still works fine in Firefox.  Both versions of Story Maps display in a different browser (Edge). 

Firefox also updated to version 95.0 (64 bit) at about the same time that this issue began.  I don't know whether the problem is related to the AWS outage or the Firefox update or something else entirely.  Has anyone else encountered this problem?  Any recommended solutions?

Thanks! 

0 Kudos
5 Replies
OwenGeo
Esri Notable Contributor

@RobinConner - I'm sorry you are having an issue with your story. We are not aware of any specific issues that sound like the one you've described, and our testing shows things working as expected on Firefox.

I'd recommend that you please contact Esri Technical Support and they can help you troubleshoot this issue with your story.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
RobinConner
New Contributor II

Thanks, Owen.  I'm using the public account, so I don't seem to be able to submit a tech support request.  I'll try a few more things and see if I can resolve it.

0 Kudos
TxNPrograms
New Contributor

I'm having the same issue.

0 Kudos
AbbyE_Esri
Esri Contributor

Hello @TxNPrograms

I am still seeing ArcGIS StoryMaps loading successfully in Firefox. Could you give a bit more detail on the exact screen you're seeing (if it is a white blank screen, or an error message), and when this issue began happening for you?

I would also be curious to see if the behavior changes when clearing your browser cache and reloading the site.

Thank you,

Abby

0 Kudos
AmySnelgrove1
New Contributor

I figured it out! We cleared cache and cookies and it worked!

Thanks!