Issue- Video Autoplay no longer working in ArcGIS StoryMaps

946
5
Jump to solution
04-11-2022 06:51 AM
Amanda__Huber
MVP Regular Contributor

Hello ArcGIS StoryMaps Team, 

I appears that video autoplay no longer works in ArcGIS StoryMaps. We're currently using Vimeo as our video hosting solution. These videos used to autoplay in your product, but as of recent they no longer play. We did confirm and the auto play parameters are correct and work on other webpages. 

Please resolve!

Thanks so much, 

Amanda Huber

1 Solution

Accepted Solutions
OwenGeo
Esri Notable Contributor

@Amanda__Huber -- Hmm, I don't think ArcGIS StoryMaps ever supported using URL parameters for 3rd party videos without using an iframe. But this story was created a long time ago so it's possible I'm not remembering correctly and this was the case for a short time.

Currently, if you want to use any URL parameters with web content like Vimeo, YouTube, Survey123, etc., you just need to add that content via iframe code (as opposed to just adding just the URL).  See the Link vs. iFrame code section of this article for more information about this: Enrich your stories with embedded web content (esri.com)

I'm able to see this working as expected. To add your video, just choose Video or Embed from the block palette and then add this code. You might want to play with the height/width a bit, if needed, but this looked best in my tests.

 

<iframe src="https://player.vimeo.com/video/697530830?h=4b996b2acb?autoplay=1&loop=1&autopause=0&background=1&muted=1" height="400" width="800"></iframe>

 

 

Owen Evans
Lead Product Engineer | StoryMaps

View solution in original post

0 Kudos
5 Replies
OwenGeo
Esri Notable Contributor

Hi @Amanda__Huber -- Sorry you are seeing an issue with your videos not autoplaying! Can you share a link to a story where this isn't working as expected so we can look into this? Do you have an idea of when you last saw it working?

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
Amanda__Huber
MVP Regular Contributor

Hi Owen, 

Great to hear from you and thanks for the quick reply!

The last project that we used video autoplay in was in Fall of 2020. Upon checking back on it, it appears to have since broken. Here's the link to the story it was used in: https://storymaps.arcgis.com/stories/b24ef2b3104e4853bcbd4457d3219804 

For our most recent project, we're using this video link: https://player.vimeo.com/video/697530830?h=4b996b2acb?autoplay=1&loop=1&autopause=0&background=1&mut... When viewed in a browser or elsewhere it works, but appears to have an issue when added as video > link in the story map or as an embed.

 

Thanks again, 

Amanda Huber

0 Kudos
OwenGeo
Esri Notable Contributor

@Amanda__Huber -- Hmm, I don't think ArcGIS StoryMaps ever supported using URL parameters for 3rd party videos without using an iframe. But this story was created a long time ago so it's possible I'm not remembering correctly and this was the case for a short time.

Currently, if you want to use any URL parameters with web content like Vimeo, YouTube, Survey123, etc., you just need to add that content via iframe code (as opposed to just adding just the URL).  See the Link vs. iFrame code section of this article for more information about this: Enrich your stories with embedded web content (esri.com)

I'm able to see this working as expected. To add your video, just choose Video or Embed from the block palette and then add this code. You might want to play with the height/width a bit, if needed, but this looked best in my tests.

 

<iframe src="https://player.vimeo.com/video/697530830?h=4b996b2acb?autoplay=1&loop=1&autopause=0&background=1&muted=1" height="400" width="800"></iframe>

 

 

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
Amanda__Huber
MVP Regular Contributor

Hi Owen, 

Okay good to know. Thanks for the resource and the code snippet. I was testing the iFrame method before, but I realize I was missing the &background=1&muted=1 in my iFrame tests (oops).

I was able to test what you sent me and the autoplay looks great! Side question- do you know if iFrame width/height are supported in the Sidecar Floating Panel? When modifying the height/width I'm still seeing white borders  along the sides and the video doesn't fill the screen: 

Amanda__Huber_0-1649691889923.png

 

Thanks again 🙂 

 

0 Kudos
OwenGeo
Esri Notable Contributor

We don't have as many options for linked videos as we do for uploaded videos because linked videos are a little more difficult for us to work with since they are coming from 3rd party services. Linked videos are currently always sized to fit to the media panel space (so you'll always see those bars). 

Upload videos fill the media panel (and you can autoplay them). For now, uploading would be your only option if you want that experience.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos