Custom map extent problems

269
5
08-29-2019 09:20 AM
LukeFawcett1
New Contributor II

I'm just starting to test out the "next gen" Story Maps. I created two story maps, each with a map or two in the main frame, and a few more maps in sidecars. Every map has a custom extent to showcase/zoom in on the particular layer or feature. However, the custom map extent doesn't always persist. It's inconsistent - sometimes it stays at the custom extent with no problem, other times I'll set the extent multiple times in edit mode, finally get it to persist in edit mode, and then the custom extent disappears when in view mode (reverts back to showing the full extent of the map).

This problem has affected the maps in both the main frame and the sidecars. There is not one specific map that is affected - it's just about every map I've tried.

When I have several slides in the sidecar, each with a map, the last slide seems to generally stay at its custom extent. In addition, the previous slides with maps, while initially at the default extent, will revert back to the custom extent if I scroll down past them and then back up. (Default extent while scrolling down, custom extent when I scroll back up). When there's only 1 slide in the sidecar, the map tends to be stuck in the default extent, rather than the custom extent.

Anyone else running into this issue?

0 Kudos
5 Replies
OwenGeo
Esri Notable Contributor

Hi Luke -- I'm sorry you are having trouble configuring map extents in your story. I just went in and was able to configure and save map extents everywhere you mentioned without an issue.

Can you please confirm how/where you are configuring the extent? Please note that to save the map extent you need to be in the map designer (see below), either when you first add the map or by clicking the pencil in the toolbar that appears when you hover over a map.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
LukeFawcett1
New Contributor II

Hi Owen,

Yes, I am going in to the map designer via the pencil icon in the main story map, zooming in/out to the desired extent, and then hitting "Place map," which as I understand should save the extent that is currently in the map designer. Setting the custom extent initially does work the majority of the time - I'll go into map designer, zoom in/out, hit "Place map" and then it will look good in Edit mode, but when I go to View, or re-open in Edit mode later, the custom extent will be lost. Sometimes it comes back after a refresh, and sometimes I have to go into Edit mode and reset the custom extent - it seems pretty random as to whether the problem occurs or not.

0 Kudos
OwenGeo
Esri Notable Contributor

Luke — Could you please clarify one more thing? Note that you need to publish changes to see any edits to the sidecar map extents when viewing your published story. So if you see a purple badge at the top of the story that says “Unpublished changes” the map extents shown in edit mode (unpublished changes) may differ from those in view mode (published story). Are the map extents shown when you click Preview in the header the ones you expect?

This wouldn’t explain why the saved extent isn’t seen back in Edit mode later, but that issue seemed less frequent, so I wanted to confirm your workflow to be sure.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
LukeFawcett1
New Contributor II

I had to double check, because I believe there were times when I hit "Preview" before publishing the changes (is that a problem? I thought "Preview" let you see your changes in View mode before publishing?). However, I just tried with my 2 story maps - changed the map extents, published, and then viewed - and the problems persisted.

0 Kudos
OwenGeo
Esri Notable Contributor

Hi Luke -- Unfortunately, we're still not able to reproduce this on our end. At this point I'd recommend that you please contact Esri Support. They are better able to help you troubleshoot a specific issue like this.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos