Area Solar Radiation: Failed to open raster dataset

6752
17
11-19-2010 03:15 AM
by Anonymous User
Not applicable
Original User: Greforb

I tried to do some calculations on solar radiation in ArcGis 10. I use the Area Solar Radiation tool, and no matter what settings I use, I keed getting the error: Failed to open raster dataset. I Tried doing it both in ArcMap and in Python, using the following command:
AreaSolarRadiation("K:/Raster/dem.img","45,0","2800","WholeYear   2009","14","0,5","NOINTERVAL","1","FROM_DEM","32","8","8","UNIFORM_SKY","0,3","0,5",'','','')

I get the full error:
Traceback (most recent call last):
  File "C:\Users\Gis\Desktop\vg.py", line 7, in <module>
    AreaSolarRadiation("K:/Raster/dem.img","45,0","2800","WholeYear   2009","14","0,5","NOINTERVAL","1","FROM_DEM","32","8","8","UNIFORM_SKY","0,3","0,5",'','','')
  File "C:\Program Files (x86)\ArcGIS\Desktop10.0\arcpy\arcpy\sa\Functions.py", line 5953, in AreaSolarRadiation
    out_direct_duration_raster)
  File "C:\Program Files (x86)\ArcGIS\Desktop10.0\arcpy\arcpy\sa\Utils.py", line 47, in swapper
    result = wrapper(*args, **kwargs)
  File "C:\Program Files (x86)\ArcGIS\Desktop10.0\arcpy\arcpy\sa\Functions.py", line 5933, in wrapper
    out_direct_duration_raster)
  File "C:\Program Files (x86)\ArcGIS\Desktop10.0\arcpy\arcpy\geoprocessing\_base.py", line 474, in <lambda>
    return lambda *args: val(*gp_fixargs(args))
ExecuteError: ERROR 999999: Error executing function.
Failed to open raster dataset
Failed to execute (AreaSolarRadiation).

From which it seems to be the out_direct_duration_raster which is causing the trouble. However, this is optional, so I don't get why. I tried giving it a path for the out_direct_duration_raster, which does not help either.

I also tried to do a repair of the installation because I read somewhere else here on the forums that that might help. No luck though!

Any suggestions are greatly appreaciated
0 Kudos
17 Replies
DiegoVallmitjana
New Contributor
I have the exact some problem..
I not checked form pyton if i see the same errors, but looks impossible to calculate with this tool. The tool Always fails, and generates empty rasters.
0 Kudos
by Anonymous User
Not applicable
Original User: Greforb

One further note: I already installed the new service pack, so that's not the problem.
0 Kudos
PederBøcher
New Contributor III
I get the same problem, and I do also have service pack 1 installed.
0 Kudos
by Anonymous User
Not applicable
Original User: petter.nyman

same problem here - solutions anyone???
0 Kudos
RyanLiddell
New Contributor
I've been using this tool a lot lately and ran into a couple of problems. On a brand new laptop (Windows 7 with an Intel i5 chipset), it will run even with a very large raster as the input -- as long as I turn background processing off. That problem is less of a headache.

On an older workstation (Windows XP, Intel Core 2, 3Ghz, 3.25 GB RAM) I get the "Failed to open raster dataset" error. ESRI support informed me that the size of the raster input is the culprit for that error. The only workaround I know of is to chop up the input rasters. In general I've found that if I chop up me raster inputs to a fize size of 50MB or less the tool will run on the workstation.
0 Kudos
by Anonymous User
Not applicable
Original User: rdebruyn

Ryan have you contacted support or already have an incident number?

Wondering if you can provide the input data and steps/settings you used to produce the error.

What size(rows columns) and format is your input data.

Thank you,
Ryan DeBruyn
ESRI - Spatial Analyst Team
0 Kudos
AndrewBlakey1
New Contributor II
Hello:

I just wanted to add that I am having the same problem as mentioned a few times above.

I will configure Area Solar Radiation as I have dozens of times before in ArcGIS 9.3, and a few seconds in, it will fail. An empty raster will be generated. There is no error message of any kind. In the Results, it just shows the red X stating that the process failed.

The solution has been to just run the tool in ArcGIS 9.3 on a different computer.

Please let me know if I can be of any help. I hope to see this problem resolved as the tool plays a significant role in my Master's thesis. Swapping data between servers is frusterating, especially since the geodatabases don't like being loaded in Arc 9 after being created in Arc 10.

Thanks!
0 Kudos
by Anonymous User
Not applicable
Original User: jbswain

I would echo what Ryan mentioned to please log a Support incident.  Without the data and a reproducible case, it is difficult to fix these problems.  Providing the data to Support will get the case reported to Development and then a fix or workaround is more likely to be determined.
0 Kudos
DungNguyen
New Contributor
is there any new update for this issue. I still have problem running solar radiation analysis on ArcGIS 10
0 Kudos