Is there any specific roadmap when ArcGIS Runtime supports the new Qt 6 version?

334
2
04-06-2021 05:40 AM
GEOINT_ENGINEER
Esri Contributor

The Qt guys did a great job getting rid of legacy implementations and uses the native graphics API of each operating system, now. They also made it possible developing Qt Quick Apps without the QML JavaScript runtime.

Would you be so kind and tell us when the ArcGIS Runtime for Qt is going to support the new Qt 6 version?

Tags (2)
0 Kudos
2 Replies
LucasDanzinger
Esri Frequent Contributor

@GEOINT_ENGINEER - we are currently investigating what it will take for us to support Qt 6, and how that will impact our support for Qt 5.  How rapidly we move to Qt 6 will greatly depend on demand and customer feedback. If you could send me details on your requirements and timelines for Qt 6 support, that would be invaluable for our decision making. Thank you.

GEOINT_ENGINEER
Esri Contributor

Currently, we are using the Open Source version of the Qt Framework SDK. The Qt company decided to make the LTS releases only available to commercial licenses. In January the Qt company made the 5.15 LTS readonly for the Open Source version. Any necessary bugfix will only be published into the commercial branch of 5.15 and the latest release e.g. Qt 6.x.

Right now, we have to keep up with the "Qt release pace" and always support the latest Qt release when using the Open Source version or risk that serious security issues will not be fixed - which is not a valid option for serious development.

The only two options we see so far is to move away from the Open Source version or unluckily pull out the whole Qt technology stack and replace it with some alternatives. I have to discuss that with our sales and business advisors in first place.

0 Kudos