Build QT app by ArcGIS SDK

207
1
12-27-2019 11:37 AM
fatemehpoormohammad
New Contributor

Hi,

I Installed QT 5.9.5 and ArcGIS runtime SDK 100.2 on the Linux platform ubuntu 18.4. I followed the instruction on your tutorial page but still have a problem with building my own app. whenever I create a quick or QML app in QT or click on ArcGIS SDK icon it shows just a grey screen and in upper version requests a certificate file which I don't know how to get! I tried any version but the problem insists.

what goes wrong?

Tags (2)
0 Kudos
1 Reply
LucasDanzinger
Esri Frequent Contributor

It seems like an OpenSSL issue. Qt requires OpenSSL and depending on Qt version and Linux version, you may need to build it yourself. For example, Qt 5.9 may require OpenSSL that is provided by default in Ubuntu 16 but not 18. Some additional details about OpenSSL & Qt are here - System requirements for 100.7.0—ArcGIS Runtime SDK for Qt | ArcGIS for Developers 

0 Kudos