Symbology from ArcServer hosted map layer not showing up on developed application

606
1
07-09-2019 05:45 AM
MattWard
New Contributor

Hi guys,

I have a hosted map layer that I am publishing up as a service on a work server. Upon running my application, the symbology that I have chosen (the green circle and triangle) will not show up in the legend, nor on the map.

What's really weird about this is is started happening randomly, and I'm not sure why. I even reverted back to a previous version of the code (from a month ago) where I know it worked fine. However, the issue still persists. Was it a Windows update? an ESRI one? I do not know! I have tried re-making the service as well, no luck. If I host the feature layer on an ArcOnline web map, it works fine. I can add a point fine to the map and it will store the information - just - there is no symbol added. 

So it has me confused. If I reverted back to a working version of the code, and it still doesn't work, is it the MXD and service malfunctioning? But since the feature layer displays correctly in a web map, is it the code malfunctioning? I am at a loss!

Hope you can help!

ArcMap 10.3.1

.NET 4.7.2

.ArcGISRuntime.Toolkit 100.4.0

Esri.ArcGISRuntime.WPF 100.5.0

0 Kudos
1 Reply
MichaelBranscomb
Esri Frequent Contributor

Matt,

It sounds like you're running into the issue addressed by this patch: https://community.esri.com/community/developers/native-app-developers/blog/2019/07/24/announcing-the... 

Cheers

Mike

0 Kudos