QueryFeaturesAsysnc and Signing

312
2
06-17-2019 01:49 PM
KayugaSolution
New Contributor

I have a program that I wrote to connect to a feature service.  I get an exception when I call QueryFeaturesAsysnc (see attachment).  This application used to work but the Test Certificate expired and had to be recreated.  I'm wondering if I'm not creating the certificate correctly?

For the Signing portion of the application properties I am doing the following:

1.  Check the "Sign the ClickOnce manifest"

2.  Create Test Certificate using sha256RSA and no password.

3.  Leave the "Timestamp server URL" blank and "Sign the assembly" unchecked.

Is this the correct way to sign my esri WPF application?

Tags (1)
0 Kudos
2 Replies
MichaelBranscomb
Esri Frequent Contributor

HI,

Have you tried the steps to update an expired certificate in the docs under https://docs.microsoft.com/en-us/visualstudio/deployment/securing-clickonce-applications ?

Cheers

Mike

0 Kudos
KayugaSolution
New Contributor

Thanks for the quick response.  I forgot that esri requires a newer version of the .Net framework now.  Since I hadn't worked on this project for a while it was targeting 4.5.2.  Now that I'm using 4.7.2 everything is good!

0 Kudos