Deployment Manifest Designer Not Working

3437
5
Jump to solution
11-13-2014 09:45 AM
LukePatterson
New Contributor III

Following the guidelines here: Create an ArcGIS Runtime deployment—ArcGIS Runtime SDK for .NET | ArcGIS for Developers

The manifest designer  isn't opening in visual studio 2013. I get an error box saying "The operation could not be completed. Invalid pointer." when I attempt to open the Deployment.arcgisruntimemanifest file.

0 Kudos
1 Solution

Accepted Solutions
LukePatterson
New Contributor III

Manually setting project output type to WinExe got the manifest tool working for me. Note: I'm working on a COM component that's hosted in an MFC application. I don't have a project that should have an output type of exe in my solution.

So recap...

This wasn't working because my .proj file didn't have the following attributes:

<ProjectTypeGuids>{60dc8134-eba5-43b8-bcc9-bb4bc16c2548};{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}</ProjectTypeGuids>

and

<OutputType>WinExe</OutputType>

Ultimately, I ended up adding an empty ArcGis Runtime project to my Solution called Deployment that I use solely for building my deployment package.

View solution in original post

0 Kudos
5 Replies
LukePatterson
New Contributor III

Upon further investigation have the following import added to my project:

$(Registry:HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\ArcGISRuntimeSDKNET10.2.4@InstallDir)ideintegration\ArcGISRuntime.targets"

I have replaced it with the correct registry key:

$(Registry:HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ESRI\ArcGISRuntimeSDKNET10.2.4@InstallDir)ideintegration\ArcGISRuntime.targets"

The manifest designer still does not come up and every attempt to build/or open the designer prompts me to update my project to support ArcGISRuntime deployment build extensions. Clicking yes updates my project to import using the wrong registry key.

0 Kudos
LukePatterson
New Contributor III

That may be the correct registry path and then it gets redirected to Wow6432Node on requesting. Not sure how that works.

0 Kudos
LukePatterson
New Contributor III

I have made progress now. My project didn't have a ProjectTypeGuids attribute in the project file. I created a new WPF project in visual studio and copied the attribute:

<ProjectTypeGuids>{60dc8134-eba5-43b8-bcc9-bb4bc16c2548};{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}</ProjectTypeGuids>

over into the project I am working on. Now the manifest designer comes up but my options are very limited compared to what I see on the example page. In fact I have three check boxes:

- ArcGIS Runtime

-Specialized Symbology

-Local Server

Is there a specific project type guid that I need to add to see more options? Or some other configuration for my project that I need to update?

0 Kudos
LukePatterson
New Contributor III

Manually setting project output type to WinExe got the manifest tool working for me. Note: I'm working on a COM component that's hosted in an MFC application. I don't have a project that should have an output type of exe in my solution.

So recap...

This wasn't working because my .proj file didn't have the following attributes:

<ProjectTypeGuids>{60dc8134-eba5-43b8-bcc9-bb4bc16c2548};{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}</ProjectTypeGuids>

and

<OutputType>WinExe</OutputType>

Ultimately, I ended up adding an empty ArcGis Runtime project to my Solution called Deployment that I use solely for building my deployment package.

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

Currently the deployment tool does require your project type to be an application (targeting Desktop, Store or Phone). We are aware this needs to be better documented and are also investigating ways in which the deployment experience can better support developers building components to include in other app projects.

Cheers

Mike

0 Kudos